Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#32086 closed defect (fixed)

szip 2.1: checksum mismatch because of stealth update

Reported by: bonomo@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: checksum Cc: josephwinston (Joseph Winston)
Port: szip

Description

Attempt to install the port gnudatalanguage failed when it attempted to install the dependency szip. I did a clean and attempted to reinstall szip separately twice. It failed both times with a checksum error. Install attempt was on a MacBook Pro (Intel) running OS 10.5.8. Xcode is version 3.1.4. All other dependencies prior to szip were downloaded and installed without incident. I assume that this is a checksum error on the server. I do not know how to obtain the email address of the maintainer of this package. I was hoping whoever reads this could help.

Attachments (2)

szipfailinstall.txt (2.2 KB) - added by bonomo@… 8 years ago.
screen output of "sudo port -v install szip" command
szip-changes.diff (11.0 KB) - added by ryandesign (Ryan Schmidt) 8 years ago.
changes between last version of szip 2.1 and current version

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by bonomo@…

Attachment: szipfailinstall.txt added

screen output of "sudo port -v install szip" command

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned
Summary: checksum failure when installing szipszip 2.1: checksum mismatch because of stealth update

Confirmed. szip 2.1 has been stealth-updated again, as has happened three times before (r42706, r78379, and r81067).

According to "port info szip", this port has no maintainer, but I'll take care of it.

Changed 8 years ago by ryandesign (Ryan Schmidt)

Attachment: szip-changes.diff added

changes between last version of szip 2.1 and current version

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

For reference, here is a diff of the changes between the last version of szip 2.1 and the current version of 2.1; looks reasonable enough.

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

comment:4 Changed 8 years ago by bonomo@…

Thank you very much for your rapid action. I did manage to locate an e-mail address at the HFD group, and got a ticket started there too. I've passed on the information about the activity here. I hope that someone there will step forward to take responsibility for preventing stealth updates, etc.

comment:5 Changed 8 years ago by josephwinston (Joseph Winston)

Cc: josephwinston@… added

Cc Me!

comment:6 Changed 8 years ago by bonomo@…

Resolution: fixed
Status: closedreopened

Sorry, but the build still fails with a checksum error for some reason! Here is the screen output:

Aquinas-195:~ bonomo$ sudo port clean --all szip
--->  Cleaning szip
Aquinas-195:~ bonomo$ sudo port -v install szip
--->  Fetching archive for szip
--->  szip-2.1_3.darwin_9.i386.tbz2 doesn't seem to exist in /opt/local/var/macports/software/szip
--->  Attempting to fetch szip-2.1_3.darwin_9.i386.tbz2 from http://packages.macports.org/szip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
--->  Fetching szip
--->  szip-2.1.tar.gz doesn't seem to exist in /opt/local/var/macports/distfiles/szip/2.1_3
--->  Attempting to fetch szip-2.1.tar.gz from http://www.hdfgroup.org/ftp/lib-external/szip/2.1/src/
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  374k  100  374k    0     0   246k      0  0:00:01  0:00:01 --:--:--  275k
--->  Verifying checksum(s) for szip
--->  Checksumming szip-2.1.tar.gz
Error: Checksum (sha1) mismatch for szip-2.1.tar.gz
Portfile checksum: szip-2.1.tar.gz sha1 fe133444a7e3ab41a48fb61f90ac7d9a473443d1
Distfile checksum: szip-2.1.tar.gz sha1 d241c9acc26426a831765d660b683b853b83c131
Error: Checksum (rmd160) mismatch for szip-2.1.tar.gz
Portfile checksum: szip-2.1.tar.gz rmd160 8b36e034e7b48d436973ade7043a42ea899697b6
Distfile checksum: szip-2.1.tar.gz rmd160 058d85cbbc9893bdda64e4c4ee967a773ae85e3a
The correct checksum line may be:
checksums           sha1    d241c9acc26426a831765d660b683b853b83c131 \
                    rmd160  058d85cbbc9893bdda64e4c4ee967a773ae85e3a
Error: Target org.macports.checksum returned: Unable to verify file checksums
Warning: the following items did not execute (for szip): org.macports.activate org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Log for szip is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_archivers_szip/szip/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
Aquinas-195:~ bonomo$ 

It appears to be unsatisfied with the szip it gets from macports (perhaps because of the version number?), and proceeds to download it from hdfgroup.org. The checksum check fails as before.

Thank you.

Rich

comment:7 in reply to:  6 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

You need to run "sudo port clean szip" and "sudo port selfupdate" to receive the fix I committed earlier.

comment:8 Changed 8 years ago by bonomo@…

Thank you again. szip installed just fine after the macport selfupdate. gnudatalanguage is continuing to install as I type this.

Note: See TracTickets for help on using tickets.