Opened 7 years ago

Closed 7 years ago

#32093 closed defect (duplicate)

libmemcached: clang: error: cannot specify -o when generating multiple output files

Reported by: jmaclabs@… Owned by: brett@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: lion clang Cc: ryandesign (Ryan Schmidt)
Port: libmemcached

Description (last modified by ryandesign (Ryan Schmidt))

Installation failure due to "shell command failed"

Mac OS X Lion 10.7.2 (11C74) running XCode 4.2 (4D199)

I executed the suggested alternate install commands for those running XCode 4.2 that specify the compiler but I got the same error each time.

:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for libmemcached): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:error:build Failed to install libmemcached
:debug:build couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing
"open [file join $dir tclIndex]"
:notice:build Log for libmemcached is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libmemcached/libmemcached/main.log

Attachments (1)

main.log (5.3 KB) - added by jmaclabs@… 7 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libmemcached/libmemcached/main.log

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by jmaclabs@…

Checked for presence of 'tclIndex' and it's indeed not found.

jmac@foo: /System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources   
➺ ls
BridgeSupport Documentation Info.plist    Scripts       license.terms tcl8          version.plist

Actual location of tclIndex is:

/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/Scripts/tclIndex

comment:2 Changed 7 years ago by jmaclabs@…

Cc: jmaclabs@… added

Cc Me!

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: jmaclabs@… removed
Description: modified (diff)
Keywords: php5 memcached xcode removed
Owner: changed from macports-tickets@… to ryandesign@…

None of the error you've shown is relevant. Please "sudo port clean php5-memcached" and "sudo port install php5-memcached" and attach the main.log.

Changed 7 years ago by jmaclabs@…

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libmemcached/libmemcached/main.log

comment:4 Changed 7 years ago by jmaclabs@…

The log snippet I included in the original description is taken from the main.log. I have attached that log.

The problem appears to be straight forward:

:debug:build couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing

The file 'tclIndex' is not found in the location expected.

Upon investigation of my recently upgraded Mac OS X Lion system, the file was found here:

/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/Scripts/tclIndex

I don't know why tclIndex is now located in the "Scripts" directory after my Lion OS upgrade, but, there it is.

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: clang added
Owner: changed from ryandesign@… to brett@…
Port: libmemcached added; php5-memcached removed
Summary: php5-memcached @1.0.2 install fails on mac os x lion with xcode 4.2libmemcached: clang: error: cannot specify -o when generating multiple output files

The tclIndex errors are spurious and not related to the problem.

The real first error in the log seems to be:

clang: error: cannot specify -o when generating multiple output files

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #31790.

Note: See TracTickets for help on using tickets.