Opened 9 years ago

Closed 9 years ago

#32100 closed submission (fixed)

New port: R.app

Reported by: kjell.konis@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt), cubranic@…, Sam.Halliday@…, haroldpimentel@…, drkp (Dan Ports)
Port: R-app

Description

R.app is a graphical user interface for the R provided in R-framework port. The current version of the R.app port (1.42 svn 5933) needs the R-framework port to be version 2.14.0 so there is a diff attached to update that port too.

Attachments (5)

Portfile (1.3 KB) - added by kjell.konis@… 9 years ago.
Portfile for the R.app port.
R-framework.Portfile.diff (868 bytes) - added by kjell.konis@… 9 years ago.
Update for the R-framework port.
R-app.Portfile (1.3 KB) - added by kjell.konis@… 9 years ago.
Same as Portfile except port is named R-app.
R-app143.Portfile (1.3 KB) - added by kjell.konis@… 9 years ago.
R-app Portfile compatible w/ R-framework 2.14.1 (older versions can be discarded)
Portfile.2 (1.2 KB) - added by kjell.konis@… 9 years ago.
R GUI 1.50 Portfile (for R-framework 2.14.2)

Download all attachments as: .zip

Change History (21)

Changed 9 years ago by kjell.konis@…

Attachment: Portfile added

Portfile for the R.app port.

Changed 9 years ago by kjell.konis@…

Attachment: R-framework.Portfile.diff added

Update for the R-framework port.

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

You originally submitted R-framework as R.framework and we decided that a dot was unusual in a port name. Can this port be R-app as well then?

comment:2 in reply to:  description Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Replying to kjell.konis@…:

needs the R-framework port to be version 2.14.0 so there is a diff attached to update that port too.

r87351.

comment:3 in reply to:  1 Changed 9 years ago by kjell.konis@…

Replying to ryandesign@…:

You originally submitted R-framework as R.framework and we decided that a dot was unusual in a port name. Can this port be R-app as well then?

I remember. I did check this time and there is already one port (Yap.app) that has a dot app extension. In contrast there are none that have dot framework. This time it's a little trickier because a lot of people refer to the R GUI as R.app (as in R dot app) and it's that port that I expect people will install -- the name of the R-framework port is not so important since it will get installed as a dependency. Anyway, I don't really understand why there is a preference (or rule? or guideline?) for not having dots in port names. If you prefer to have the port named R-app let me know and I will make the change.

comment:4 Changed 9 years ago by Sam.Halliday@…

Cc: Sam.Halliday@… added

Cc Me!

comment:5 Changed 9 years ago by Sam.Halliday@…

I'm very keen to see this port make it into macports. I note some current dependency problems and workarounds that users might currently encounter:

# llvm-gcc #

#31663

## Summary ##

Apple's system compiler (LLVM C compiler, with a gcc front-end) doesn't come with a fortran compiler. However, an "Apple Framework"-compatible fortran compiler is needed in order to build the R-framework.

The current port of the llvm-gcc42 (which includes a duplicate of the system C compiler) will be built by the apple-gcc if it is available (Apple's pre-Lion fork of GCC, a dependency of some macports). Unfortunately, apple-gcc fails to build the llvm-gcc42 and we must force it to be built using the system C compiler.

## Workaround ##

sudo port clean llvm-gcc42 # if you already tried and failed to install
sudo port install llvm-gcc42 configure.compiler=apple-gcc-4.2

# Python27 #

## Summary ##

I have no idea why my R-framework needed to build this, it might be a pending build.

There is currently a minor circular dependency bug in the python27 build, which means that the module "py27-xml" requires python27 to be built and python27 updates will depend on py27-xml. Python27 appears to be built universally by default and will fail to install if py27-xml is installed non-universally (the default).

#32090

## Workaround ##

before upgrading python27

port install py27-xml +universal

OR (easier for me)

disable py27-xml (and dependants) and then upgrade python27.

comment:7 Changed 9 years ago by Sam.Halliday@…

any idea of when we can expect to see this accepted?

Changed 9 years ago by kjell.konis@…

Attachment: R-app.Portfile added

Same as Portfile except port is named R-app.

Changed 9 years ago by kjell.konis@…

Attachment: R-app143.Portfile added

R-app Portfile compatible w/ R-framework 2.14.1 (older versions can be discarded)

comment:8 Changed 9 years ago by cubranic@…

Cc: cubranic@… added

Cc Me!

comment:9 Changed 9 years ago by Sam.Halliday@…

Cc: Sam.Halliday@… removed

Cc Me!

comment:10 Changed 9 years ago by Sam.Halliday@…

Cc: Sam.Halliday@… added

Cc Me!

comment:11 Changed 9 years ago by Sam.Halliday@…

Is this any closer to being accepted? :-)

comment:12 Changed 9 years ago by haroldpimentel@…

Cc: haroldpimentel@… added

Cc Me!

comment:13 Changed 9 years ago by Sam.Halliday@…

it has been 2 months since any updates on this new port - have there been added complications? I'm really looking forward to it!

(BTW, R-framework is a minor release out of date now)

comment:14 Changed 9 years ago by kjell.konis@…

Maintainer here: unfortunately the R-app port doesn't work with Xcode 4.3. I am in the process of trying to figure out what's wrong. Also, there is an update for the R-framework port in #33513.

Changed 9 years ago by kjell.konis@…

Attachment: Portfile.2 added

R GUI 1.50 Portfile (for R-framework 2.14.2)

comment:15 Changed 9 years ago by kjell.konis@…

OK, looks like the problem is that R.app is not clangpatible - using llvmgcc42 fixes the problem. Also, oddly setting xcode.destroot.settings to ${xcode.build.settings} doesn't work (a } gets appended to the variable) - hence the identical lines. Not sure if this is a problem with mp or Xcode.

comment:16 Changed 9 years ago by drkp (Dan Ports)

Cc: dports@… added

Cc Me!

comment:17 Changed 9 years ago by drkp (Dan Ports)

Port: R-app added
Resolution: fixed
Status: newclosed

Committed R-app in r91504, using the updated portfile from #33844.

Note: See TracTickets for help on using tickets.