Opened 6 years ago

Last modified 4 years ago

#32141 new defect

munin node fail to update with "Plugin XYZ Can't drop privileges: setrgid()"

Reported by: jacques2020@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Lion Cc: kenyon@…
Port: munin

Description (last modified by ryandesign (Ryan Schmidt))

Hi

When calling the any plugin on Lion via telnet, it results in the same error (see below some modifications needed to successfully install)

Trying 129.20.159.199...
Connected to pr159199.med.univ-rennes1.fr.
Escape character is '^]'.
# munin node at pr159199.med.univ-rennes1.fr
fetch df
# Bad exit
.
cap
cap multigraph
list
cupsys_pages df df_inode if_en0 if_err_en0 load lpstat netstat ntp_offset postfix_mailqueue processes test users

while it run fine using munin-run on the node computer

sudo -u munin /opt/local/sbin/munin-run df
Password:
_dev_disk0s2.value 4
_dev_disk3.value 100
_dev_disk1s3.value 19
_dev_disk2s2.value 100
_dev_disk4s2.value 33

and here is the corresponding munin-node.log

2011/11/19-19:31:45 CONNECT TCP Peer: "129.20.159.165:48055" Local: "129.20.159.199:4949"
2011/11/19-19:31:45 [2392] DEBUG: > # munin node at pr159199.med.univ-rennes1.fr
2011/11/19-19:31:53 [2392] DEBUG: < fetch df
".11/11/19-19:31:53 [2392] DEBUG: Running command "fetch df
2011/11/19-19:31:53 [2392] Error output from df:
2011/11/19-19:31:53 [2392] 	# Set /rgid/ruid/egid/euid/ to /500/4294967294/500 500 /4294967294/
2011/11/19-19:31:53 [2392] 	2011/11/19-19:31:53 [2393] Plugin 'df' Can't drop privileges: setrgid() not implemented at /opt/local/lib/perl5/site_perl/5.12.3/Munin/Node/OS.pm line 272, <STDIN> line 1.\n. Bailing out.
2011/11/19-19:31:53 [2392] Service 'df' exited with status 1/0.
2011/11/19-19:31:53 [2392] DEBUG: > # Bad exit
2011/11/19-19:31:53 [2392] DEBUG: > .
2011/11/19-19:31:58 [2392] DEBUG: < cap
".11/11/19-19:31:58 [2392] DEBUG: Running command "cap
2011/11/19-19:31:58 [2392] DEBUG: > cap multigraph
2011/11/19-19:32:01 [2392] DEBUG: < list
".11/11/19-19:32:01 [2392] DEBUG: Running command "list
2011/11/19-19:32:01 [2392] DEBUG: > cupsys_pages df df_inode if_en0 if_err_en0 load lpstat netstat ntp_offset postfix_mailqueue processes test users
2011/11/19-19:32:01 [2392] DEBUG: > 
2

I experience difficulties in installing minion node on snow leopard (PPC and intel core 2 duo as well as Lion / intel Xeon and i5)

First of all, after installing, I tried to run

sudo munin-node-configure --suggest --shell | sh

I got an error

Could not open plugin configuration directory: No such file or directory at /opt/local/lib/perl5/site_perl/5.12.3/Munin/Node/Service.pm line 81

Looking at the code, I assumed that

sudo mkdir /opt/local/etc/munin/plugin-conf.d

could fix the issue… In fact the plugin folder could not be written by an admin and sh seems to be sudo, like

sudo munin-node-configure --suggest --shell | sudo sh

on Lion, none of the plugin succeeded in autoconf with message

Non-zero exit during autoconf (1)

So, I also had to run as munin user

sudo -u munin munin-node-configure --suggest --shell | sudo sh

(but there is still an issue with asking for password if the precedent sudo is not recent enough…)

it might be interesting to dig into that or at least to when it is suggested to run the munin-node-configure to add the proper command.

thank you for your help

Change History (8)

comment:1 follow-up: Changed 6 years ago by ryandesign (Ryan Schmidt)

  • Description modified (diff)
  • Keywords munin 10.7 removed
  • Owner changed from macports-tickets@… to alpha@…

Please remember to use WikiFormatting so your posts are legible.

There is no such thing as Snow Leopard for PowerPC.

comment:2 in reply to: ↑ 1 Changed 6 years ago by jacques2020@…

Hi,

Thank you for the formating. Indeed, in the comparison, the PPC runs Leopard (not snow ~); Sorry :-) However, the reported problem is on Lion (10.7)

Best

J.

comment:3 Changed 5 years ago by raimue (Rainer Müller)

I attached a patch to #32573 which should fix the initial setup of munin and probably resolves this ticket as well.

comment:4 Changed 5 years ago by scotbuff@…

Your patch fixes the installation but does not resolve the plugins all failing. Just as the original poster mentioned, anything run via telnet fails and the same errors above show in the log file. I am running Snow Leopard. I think the issue is the "Can't drop privileges" showing in the munin-node.log file.

comment:5 Changed 4 years ago by kenyon@…

  • Cc kenyon@… added

Cc Me!

comment:6 Changed 4 years ago by matthew@…

I was able to fix this by setting the munin user in the conf file. It was set to 'user root'. I changed it to 'user munin'.

I reproduced this on Mavericks.

comment:7 Changed 4 years ago by raimue (Rainer Müller)

Has duplicate #42474.

comment:8 Changed 4 years ago by mf2k (Frank Schima)

  • Owner changed from alpha@… to macports-tickets@…

This port is no longer maintained.

Note: See TracTickets for help on using tickets.