Opened 9 years ago

Closed 8 years ago

#32191 closed submission (fixed)

new port: py-netcdf4

Reported by: jswhit (Jeff Whitaker) Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: gorticus (Jason Mitchell), petrrr
Port: py-netcdf4

Description

python interface to the netcdf library (netcdf4-python.google.com)

Attachments (4)

Portfile (1022 bytes) - added by jswhit (Jeff Whitaker) 9 years ago.
Portfile.patch (927 bytes) - added by gorticus (Jason Mitchell) 8 years ago.
Portfile patch for v0.9.9
Portfile.v0.0.9.9 (1.1 KB) - added by gorticus (Jason Mitchell) 8 years ago.
complete port file for v0.9.9
Portfile.v1.0fix1 (1.2 KB) - added by gorticus (Jason Mitchell) 8 years ago.

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by jswhit (Jeff Whitaker)

Attachment: Portfile added

comment:1 Changed 8 years ago by gorticus (Jason Mitchell)

  • I can confirm that this port, in addition to installing netcdf4, resolves problems getting netcdf4 dependent Matplotlib Basemap examples to work, in particular the day-night terminator map example at the bottom, which has a hidden import netcdftime.
  • +1 for getting this in, since it really is a basemap requirement; see ticket #27222 for previous feature request
  • py-matplotlib-basemap will need dep added for py-netcdf4 at least this issue would provide instructions to get things working until py-matplotlib-basemap could be updated

comment:2 Changed 8 years ago by gorticus (Jason Mitchell)

  • v0.9.9 was released 2011/12/12
  • mod'd Portfile, built, tested => worked
  • patch file attached

Changed 8 years ago by gorticus (Jason Mitchell)

Attachment: Portfile.patch added

Portfile patch for v0.9.9

comment:3 Changed 8 years ago by mf2k (Frank Schima)

Port: py-netcdf4 added
Version: 2.0.3

@jason: Please submit the complete portfile for the 0.9.9 version. We only needs patches for portfiles that are currently in macports.

comment:4 Changed 8 years ago by mf2k (Frank Schima)

I see a few issues that need to be corrected:

  1. openmaintainer is not a valid maintainer by itself. Use nomaintainer.
  2. Your depends_lib-append statement must be inside of a if {$subport != $name} { block.

comment:5 Changed 8 years ago by petrrr

Cc: Peter.Danecek@… added

Cc Me!

comment:6 Changed 8 years ago by jmroot (Joshua Root)

Cc: jason-macports@… added

comment:7 in reply to:  4 Changed 8 years ago by gorticus (Jason Mitchell)

Replying to macsforever2000@…:

I see a few issues that need to be corrected:

  1. openmaintainer is not a valid maintainer by itself. Use nomaintainer.
  2. Your depends_lib-append statement must be inside of a if {$subport != $name} { block.

Sorry for the delay. I only received the last 'Cc me!' email:

  • v0.9.9
    • updated per request
    • added livecheck
  • v1.0fix1
    • changes for v0.9.9, plus version update (requires change worksrcdir as version doesn't match tarball dir

Will re-upload both, as I forgot to take out some of my comments.

Changed 8 years ago by gorticus (Jason Mitchell)

Attachment: Portfile.v0.0.9.9 added

complete port file for v0.9.9

Changed 8 years ago by gorticus (Jason Mitchell)

Attachment: Portfile.v1.0fix1 added

comment:8 Changed 8 years ago by drkp (Dan Ports)

Owner: changed from macports-tickets@… to dports@…
Status: newassigned

comment:9 Changed 8 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed

Thanks! Committed in r96477.

I took the worksrcdir line out of the if {$version == "1.0fix1"} block because that will always evaluate to true with this version of the portfile, and should be removed entirely when the version changes.

Note: See TracTickets for help on using tickets.