Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#32204 closed defect (duplicate)

gtk2: GLib-ERROR (recursed) **: The thread system is not yet initialized.

Reported by: paradox924x@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt), anddam (Andrea D'Amore), bernhard.fisseni@…, louis@…, soehn@…, steven.westmoreland@…, quest@…
Port: gtk2 glib2

Description (last modified by ryandesign (Ryan Schmidt))

While updating using sudo port selfupdate and then sudo port upgrade outdated, I received the following error:

--->  Computing dependencies for gtk2
--->  Building gtk2
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for gtk2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gtk2/gtk2/main.log
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

The related file is attached as main.log

After uninstalling gtk2, gimp and all related dependencies via: sudo port uninstall gimp-app gimp-jp2 gimp-lqr-plugin gutenprint icns-gimp ufraw xsane gimp2 libgsf libgnome gst-plugins-base gnome-vfs libgnomeui libbonoboui glib-networking libproxy libsoup libgnome-keyring gnome-keyring gconf librsvg libopenraw gegl libglade2 libgnomecanvas poppler py27-gtk webkit-gtk gtk-nodoka-engine gtkimageview gtk2 and cleaning all ports files via sudo port clean all, I attempted to install gimp again (thereby installing gtk2) and received the same error (with much more verbosity in the build log).

--->  Computing dependencies for gimp
--->  Dependencies to be installed: gimp-app gimp2 gegl gtk2 libopenraw librsvg libgsf gconf gnome-vfs libgnomeui libbonoboui libgnome libgnomecanvas libglade2 libgnome-keyring gnome-keyring poppler py27-gtk webkit-gtk gst-plugins-base libsoup glib-networking libproxy gimp-jp2 gimp-lqr-plugin gtk-nodoka-engine gutenprint icns-gimp ufraw gtkimageview xsane
--->  Fetching archive for gtk2
--->  Attempting to fetch gtk2-2.24.8_1+x11.darwin_11.x86_64.tbz2 from http://packages.macports.org/gtk2
--->  Fetching gtk2
--->  Verifying checksum(s) for gtk2
--->  Extracting gtk2
--->  Applying patches to gtk2
--->  Configuring gtk2
--->  Building gtk2
Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Failed to install gtk2
Log for gtk2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_gtk2/gtk2/main.log
Error: The following dependencies were not installed: gimp-app gimp2 gegl gtk2 libopenraw librsvg libgsf gconf gnome-vfs libgnomeui libbonoboui libgnome libgnomecanvas libglade2 libgnome-keyring gnome-keyring poppler py27-gtk webkit-gtk gst-plugins-base libsoup glib-networking libproxy gimp-jp2 gimp-lqr-plugin gtk-nodoka-engine gutenprint icns-gimp ufraw gtkimageview xsane
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

The related file is attached as main2.log

Attachments (3)

main.log (9.4 KB) - added by paradox924x@… 9 years ago.
main2.log (231.6 KB) - added by paradox924x@… 9 years ago.
patch-glib2.diff (340 bytes) - added by anddam (Andrea D'Amore) 9 years ago.

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by paradox924x@…

Attachment: main.log added

Changed 9 years ago by paradox924x@…

Attachment: main2.log added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Keywords: gtk2 build fail abort thread gtkbuiltincache removed
Summary: gtk2 fails to upgrade/build on Liongtk2: GLib-ERROR (recursed) **: The thread system is not yet initialized.

The same error ("GLib-ERROR (recursed) **: The thread system is not yet initialized") was reported against mc in #32202 but I was not able to reproduce it. Must be related to the glib 2.30.2 update, possibly related to Lion. (I'm on Snow Leopard.)

comment:2 Changed 9 years ago by anddam (Andrea D'Amore)

Port: glib2 added

I'm able to reproduce this issue on Lion using clang (XCode 4.2).

Reverting glib2 from 2.30.2 to 2.28.0 let gtk2 build correctly.

comment:3 Changed 9 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added

Cc Me!

comment:4 Changed 9 years ago by bernhard.fisseni@…

Cc: bernhard.fisseni@… added

Cc Me!

comment:5 Changed 9 years ago by louis@…

Cc: louis@… added

Cc Me!

comment:6 Changed 9 years ago by soehn@…

Cc: soehn@… added

Cc Me!

comment:7 Changed 9 years ago by steven.westmoreland@…

Cc Me!

comment:8 Changed 9 years ago by steven.westmoreland@…

Cc: steven.westmoreland@… added

Cc Me!

comment:9 Changed 9 years ago by quest@…

Cc: quest@… added

Cc Me!

comment:10 Changed 9 years ago by quest@…

Compiles and works correctly with llvm-gcc-4.2

comment:11 Changed 9 years ago by ryandesign (Ryan Schmidt)

@quest: which port did you need to recompile with llvm-gcc-4.2: glib2 or gtk2?

Changed 9 years ago by anddam (Andrea D'Amore)

Attachment: patch-glib2.diff added

comment:12 Changed 9 years ago by ryandesign (Ryan Schmidt)

Andrea, we do not select the compiler based on OS version; we select it based on Xcode version. See PortfileRecipes#compiler. I'm preparing to add the relevant code now, since #32202 and #32233 show that recompiling glib2 with llvm-gcc-4.2 is indeed what fixed it.

comment:13 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

comment:14 Changed 9 years ago by ryandesign (Ryan Schmidt)

Has duplicate #32244.

Note: See TracTickets for help on using tickets.