Opened 9 years ago

Closed 9 years ago

#32317 closed defect (duplicate)

py27-wxpython build fails with Xcode 4.2

Reported by: robitaille@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: jameskyle@…, jjstickel@…
Port: py27-wxpython

Description

When trying to install py27-wxpython on MacOS 10.6, I ran into the following error:

:info:build unable to execute gcc-4.0: No such file or directory
:info:build error: command 'gcc-4.0' failed with exit status 1

It looks like wxpython tries to use gcc-4.0 which is no longer included in MacOS 10.6 by default. Other users I have spoken to have reported a similar issue on MacOS 10.7.

Full log attached.

Attachments (1)

wxpython.log (140.9 KB) - added by robitaille@… 9 years ago.
Full error log

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by robitaille@…

Attachment: wxpython.log added

Full error log

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: jameskyle@… added
Priority: HighNormal
Summary: py27-wxpython build fails on MacOS 10.6 and 10.7py27-wxpython build fails with Xcode 4.2

This problem was also mentioned in comment:ticket:30881:3, but that ticket is primarily about a different problem; this new ticket is where we should be handling it.

It's Xcode 4.2, by the way, not OS X 10.6, that eliminates the gcc compilers.

The port should be modified to ensure it's UsingTheRightCompiler and not hardcoding itself to gcc-4.0. See also PortfileRecipes#compiler. If really gcc-4.0 is necessary (if gcc-4.2 won't work), you could even fall back to the compiler in the apple-gcc40 port, if that port can still be compiled...

comment:2 Changed 9 years ago by jyrkiwahlstedt

Ok, the problem is in the wxPython source itself, it hardcodes the compiler...

comment:3 Changed 9 years ago by jyrkiwahlstedt

Portfile includes now a patch to use llvm-gcc on SL and Lion, r87762

comment:4 Changed 9 years ago by robitaille@…

My 10.6 installation is still using gcc-4.0 - it looks like the patch file is missing from r87762? (also, is the build.env-append command meant to be commented out?)

comment:5 Changed 9 years ago by robitaille@…

Should the changes not also be applied to other Python versions? (py- and py26)

comment:6 Changed 9 years ago by jjstickel@…

Cc: jjstickel@… added

Cc Me!

comment:7 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #29003.

Note: See TracTickets for help on using tickets.