Opened 9 years ago

Closed 9 years ago

#32322 closed defect (duplicate)

avidemux build fails with "invalid conversion from ‘const char**’ to ‘char**’", others

Reported by: deesto (John S. De Stefano Jr.) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: avidemux

Description

Building latest version fails with these among other errors:

...
/opt/local/var/macports/build/_opt_local_var_macports_sources_www.macports.org_files_ports_multimedia_avidemux/avidemux/work/avidemux_2.5.3/cmake_compile_check/iconv_check.cpp:12: error: invalid conversion from ‘const char**’ to ‘char**’
/opt/local/var/macports/build/_opt_local_var_macports_sources_www.macports.org_files_ports_multimedia_avidemux/avidemux/work/avidemux_2.5.3/cmake_compile_check/iconv_check.cpp:12: error:   initializing argument 2 of ‘size_t libiconv(void*, char**, size_t*, char**, size_t*)’
gmake[1]: *** [CMakeFiles/cmTryCompileExec.dir/iconv_check.cpp.o] Error 1
gmake[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_www.macports.org_files_ports_multimedia_avidemux/avidemux/work/build/CMakeFiles/CMakeTmp'
gmake: *** [cmTryCompileExec/fast] Error 2
...
make[2]: *** [avidemux/ADM_outputs/oplug_avi/CMakeFiles/oplug_avi_cli.dir/op_avisavecopy_pack.cpp.o] Error 1
make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_www.macports.org_files_ports_multimedia_avidemux/avidemux/work/build'
make[1]: *** [avidemux/ADM_outputs/oplug_avi/CMakeFiles/oplug_avi_cli.dir/all] Error 2
...

Please see the attached log, and let me know if this is an error on my part?

Attachments (1)

port-avidemux-install-debug.log (840.1 KB) - added by deesto (John S. De Stefano Jr.) 9 years ago.
port install debug log

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by deesto (John S. De Stefano Jr.)

port install debug log

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #30525.

Note: See TracTickets for help on using tickets.