Opened 9 years ago

Closed 9 years ago

#32381 closed defect (duplicate)

Failed to install gtkglext

Reported by: yuriy.dedkov@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt), jd@…
Port: gtkglext

Description (last modified by ryandesign (Ryan Schmidt))

I've tried to install gwyddion port and got an error

--->  Computing dependencies for gwyddion
--->  Dependencies to be installed: gtkglext
--->  Fetching archive for gtkglext
--->  Attempting to fetch gtkglext-1.2.0_6.darwin_11.x86_64.tbz2 from http://packages.macports.org/gtkglext
--->  Fetching gtkglext
--->  Verifying checksum(s) for gtkglext
--->  Extracting gtkglext
--->  Applying patches to gtkglext
--->  Configuring gtkglext
--->  Building gtkglext
Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Failed to install gtkglext
Log for gtkglext is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gtkglext/gtkglext/main.log
Error: The following dependencies were not installed: gtkglext
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (1)

main.log (61.0 KB) - added by yuriy.dedkov@… 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by yuriy.dedkov@…

Attachment: main.log added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… jd@… added
Description: modified (diff)
Keywords: gtkglext removed
Priority: HighNormal
Resolution: duplicate
Status: newclosed

Remember to use WikiFormatting. There's no need to repeat the port name in the Keywords field. Please Cc the port's maintainer, and don't set the Priority to High.

The error in the log is:

/opt/local/include/gdk-pixbuf-2.0/gdk-pixbuf/gdk-pixbuf-core.h:260:1: error: unknown type name 'G_CONST_RETURN'

So this is a duplicate of #32264 which was already fixed. Run "sudo port clean gtkglext" and "sudo port selfupdate" and try again.

Note: See TracTickets for help on using tickets.