Opened 9 years ago

Closed 9 years ago

#32383 closed defect (fixed)

root @5.30.03_0+fftw3 doesn't install libFFT.so

Reported by: cdeil (Christoph Deil) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: mattiafrancescomoro@…, cjones051073 (Chris Jones)
Port: root

Description

I have this installed:

root @5.30.03_0+fftw3+gsl+minuit2+opengl+python27+qt_mac+roofit+ssl+tmva+xml (active)

Still there is no libFFTW.so in /opt/local/lib/root, so executing e.g. the FFT tutorial that comes with ROOT fails:

cd /tmp
cp /opt/local/share/root/tutorials/fft/FFT.C .
root FFT.C+
root [0] 
Processing FFT.C+...
Info in <TUnixSystem::ACLiC>: creating shared library /private/tmp/./FFT_C.so
Error in <TUnixSystem::DynamicPathName>: FFTW[.so | .dll | .dylib | .sl | .dl | .a] does not exist in .:/opt/local/lib/root::/opt/local/lib/root/cint/cint/stl
Error in <TVirtualFFT::FFT>: handler not found

 *** Break *** segmentation violation

This problem is not there for me if I install ROOT from source or binary outside of Macports. I haven't looked at the Macports ROOT build log yet why /opt/local/lib/root/libFFT.so was not created.

Change History (4)

comment:1 Changed 9 years ago by cjones051073 (Chris Jones)

Thanks for the report. I'll take a look.

comment:2 Changed 9 years ago by cjones051073 (Chris Jones)

I was able to reproduce this with 5.30.03, however, the issue appear to be gone with an update to 5.32.00 I was working on.

Ticket #32400

So whilst I don't know what really was wrong, the issue is solved in that update.

comment:3 Changed 9 years ago by cdeil (Christoph Deil)

The issue is also resolved for me (Lion, XCode 4.2) with your update in ticket #32400, so feel free to close this one.

comment:4 Changed 9 years ago by pixilla (Bradley Giesbrecht)

Resolution: fixed
Status: newclosed

Changeset r87844

Note: See TracTickets for help on using tickets.