Opened 9 years ago

Closed 8 years ago

#32390 closed defect (fixed)

gnome-mime-data: build failure due to empty $GMSGFMT

Reported by: reid@… Owned by: rmstonecipher@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: gnome-mime-data

Description (last modified by ryandesign (Ryan Schmidt))

I'm filing two ports because they seem to be the same issue. Or at least the same error comes up.

gnome-mime-data:

Making all in po
make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-mime-data/gnome-mime-data/work/gnome-mime-data-2.18.0/po'
file=`echo af | sed 's,.*/,,'`.gmo \
	  && rm -f $file &&  -o $file af.po
file=`echo am | sed 's,.*/,,'`.gmo \
	  && rm -f $file &&  -o $file am.po
/bin/sh: -o: command not found
/bin/sh: -o: command not found
make[2]: *** [am.gmo] Error 127
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [af.gmo] Error 127

gnome-vfs:

Making all in po
make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-mime-data/gnome-mime-data/work/gnome-mime-data-2.18.0/po'
file=`echo af | sed 's,.*/,,'`.gmo \
	  && rm -f $file &&  -o $file af.po
file=`echo am | sed 's,.*/,,'`.gmo \
	  && rm -f $file &&  -o $file am.po
/bin/sh: -o: command not found
make[2]: *** [af.gmo] Error 127
make[2]: *** Waiting for unfinished jobs....
/bin/sh: -o: command not found
make[2]: *** [am.gmo] Error 127

Attachments (1)

main.log (31.7 KB) - added by kvitale@… 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by reid@…

Forgot to say I'm on OS 10.6.8 using Xcode 3.2.6.

comment:2 Changed 9 years ago by reid@…

Same error on:

  • gst-ffmpeg
  • gst-plugins-gl
  • gst-plugins-good
  • gst-plugins-base
  • gst-plugins-ugly

comment:3 Changed 9 years ago by reid@…

Brain fart. The gst-* all have gst-plugins-base as depends which has gnome-mime-data as a dep. Sorry.

comment:4 Changed 9 years ago by reid@…

The problem was that msgfmt wasn't found. So, I added

use_autoreconf  yes

in the Portfiles which made things install. I'm not sure if that is the proper way to do it, but it worked.

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: reid@… removed
Description: modified (diff)
Keywords: gnome-mime-data gnome-vfs removed
Owner: changed from macports-tickets@… to rmstonecipher@…
Port: gnome-vfs removed
Summary: gnome-mime-data 2.18.0/gnome-vfs 2.24.4 fails to buildgnome-mime-data: -o: command not found

Please use WikiFormatting so your posts are legible.

There is no need to repeat the port names in the Keywords field, nor do you need to Cc yourself when you reported the ticket. Please do however Cc the maintainer of the affected ports.

msgformat is a part of gettext. gnome-mime-data of course already has a dependency on gettext so I'm not sure what happened. Can you undo your change, clean, try again, and attach the main.log from the failed build?

Changed 9 years ago by kvitale@…

Attachment: main.log added

comment:6 in reply to:  5 Changed 9 years ago by kvitale@…

Replying to ryandesign@…:

msgformat is a part of gettext. gnome-mime-data of course already has a dependency on gettext so I'm not sure what happened. Can you undo your change, clean, try again, and attach the main.log from the failed build?


This was the only ticket closets to what I'm experiencing. I've attached my log file; I would appreciate any help. I cannot get gnome-mime-data to build in MacPorts.

comment:7 Changed 9 years ago by jmroot (Joshua Root)

I can't reproduce. It might help to see the config.log from an affected user.

comment:8 Changed 9 years ago by jmroot (Joshua Root)

Summary: gnome-mime-data: -o: command not foundgnome-mime-data: build failure due to empty $GMSGFMT

comment:9 Changed 8 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

Seems to only happen when using a non-default build_arch for whatever reason. r98793

Note: See TracTickets for help on using tickets.