New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #32391 (closed defect: fixed)

Opened 2 years ago

Last modified 22 months ago

Lion: cyrus-sasl @2.1.23_3+kerberos causes Incompatible library version: LDAP requires version 3.0.0 or later, but libsasl2.2.dylib provides version 0.0.0

Reported by: nelson.ferreira@… Owned by: jmpp@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: landonf@…
Port: cyrus-sasl2

Description (last modified by macsforever2000@…) (diff)

The summary says it all.

After installing cyrus-sasl I had these errors while losing programs linked to ssl, gone after uninstalling cyrus-sasl.

dyld: Library not loaded: /usr/lib/libsasl2.2.dylib
  Referenced from: /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP
  Reason: Incompatible library version: LDAP requires version 3.0.0 or later, but libsasl2.2.dylib provides version 0.0.0

Change History

comment:1 Changed 2 years ago by nelson.ferreira@…

Crash reporter details of an example:

Process:         sxemacs-22.1.14 [29161]
Path:            /opt/local/bin/sxemacs-22.1.14
Identifier:      sxemacs-22.1.14
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  bash [77754]

Date/Time:       2011-12-03 22:50:09.088 -0500
OS Version:      Mac OS X 10.7.2 (11C74)
Report Version:  9

Interval Since Last Report:          313980 sec
Crashes Since Last Report:           60
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      E1FEAF32-402E-42B6-B6C7-B8DB1512C1D0

Crashed Thread:  0

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /usr/lib/libsasl2.2.dylib
  Referenced from: /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP
  Reason: Incompatible library version: LDAP requires version 3.0.0 or later, but libsasl2.2.dylib provides version 0.0.0

Binary Images:
       0x100000000 -        0x1002e8ff7 +sxemacs (??? - ???) <6B20A423-7211-39A8-BAE5-3A178DDCA325> /opt/local/bin/sxemacs
       0x100646000 -        0x100660fff +libsxelw-Xt.0.dylib (??? - ???) <D03EF9F2-B798-3134-9176-465EA817B20B> /opt/local/lib/libsxelw-Xt.0.dylib
       0x10066f000 -        0x1006adff7 +libssl.1.0.0.dylib (??? - ???) <0880F2AA-45A2-3286-991E-1A67C1B74CFF> /opt/local/lib/libssl.1.0.0.dylib
       0x1006c4000 -        0x1007ecfff +libcrypto.1.0.0.dylib (??? - ???) <C2AA0D07-7675-3A57-9BED-DB001CF96087> /opt/local/lib/libcrypto.1.0.0.dylib
       0x100857000 -        0x100872ff7  libpq.5.dylib (5.3.0 - compatibility 5.0.0) <067649A2-F2EA-352F-AA67-CB0FFA59D9C9> /usr/lib/libpq.5.dylib
       0x10087d000 -        0x1008d7fdf +libgmp.10.dylib (11.2.0 - compatibility 11.0.0) <05463146-A15C-31C9-8517-299C76B608FC> /opt/local/lib/libgmp.10.dylib
       0x1008e4000 -        0x10093bff7 +libtiff.3.dylib (13.5.0 - compatibility 13.0.0) <D371F602-5352-390B-97A7-F260DF3151A9> /opt/local/lib/libtiff.3.dylib
       0x100947000 -        0x100965fff +libpng14.14.dylib (23.0.0 - compatibility 23.0.0) <DF2C4887-F55A-340F-A85F-CCC4E8EDE7F7> /opt/local/lib/libpng14.14.dylib
       0x10096d000 -        0x1009a1ff7 +libjpeg.8.dylib (12.0.0 - compatibility 12.0.0) <547B0670-CCE5-315A-BECC-E3F818C76388> /opt/local/lib/libjpeg.8.dylib
       0x1009a8000 -        0x1009aaff7 +libcompface.0.dylib (1.5.2 - compatibility 1.5.2) <BCD91461-F4C1-382C-8039-0FE51937D8E2> /opt/local/lib/libcompface.0.dylib
       0x1009b9000 -        0x1009c6fff +libXpm.4.dylib (16.0.0 - compatibility 16.0.0) <E5E6977D-EE43-3F31-944F-AE3344269818> /opt/local/lib/libXpm.4.dylib
       0x1009cb000 -        0x100a19ff7 +libXaw.7.dylib (8.0.0 - compatibility 8.0.0) <AAFC320F-C6C8-37D2-9ACD-2CB9EB2A0BFE> /opt/local/lib/libXaw.7.dylib
       0x100a36000 -        0x100a48fff +libXmu.6.dylib (9.0.0 - compatibility 9.0.0) <F585D672-702A-3C5E-A6E9-86FBBBB8020E> /opt/local/lib/libXmu.6.dylib
       0x100a51000 -        0x100a97fff +libXt.6.dylib (7.0.0 - compatibility 7.0.0) <DA9EB881-3DC7-3FF2-84D2-B17721560EA8> /opt/local/lib/libXt.6.dylib
       0x100aaf000 -        0x100abcff7 +libXext.6.dylib (11.0.0 - compatibility 11.0.0) <F8FA5759-7C9D-3B4C-AA8F-6340A4110E7D> /opt/local/lib/libXext.6.dylib
       0x100ac2000 -        0x100bd5fff +libX11.6.dylib (10.0.0 - compatibility 10.0.0) <32ADB232-24AC-374A-9CAD-BCB19D5E5B1C> /opt/local/lib/libX11.6.dylib
       0x100bf8000 -        0x100c0aff7 +libxcb.1.dylib (3.0.0 - compatibility 3.0.0) <3E865F0D-7436-3AE6-98EC-D3D62739B582> /opt/local/lib/libxcb.1.dylib
       0x100c18000 -        0x100c19ff7 +libXau.6.dylib (7.0.0 - compatibility 7.0.0) <3F48CAF4-6DEC-3935-ADC4-67733BCFAE1F> /opt/local/lib/libXau.6.dylib
       0x100c1c000 -        0x100c1ffff +libXdmcp.6.dylib (7.0.0 - compatibility 7.0.0) <73C33B9B-EF3A-3C2D-B79B-4C64AD5AA99D> /opt/local/lib/libXdmcp.6.dylib
       0x100c22000 -        0x100c27ff7 +libSM.6.dylib (7.1.0 - compatibility 7.0.0) <D60FB83A-8F6F-3879-A4E8-AA20A186247A> /opt/local/lib/libSM.6.dylib
       0x100c2b000 -        0x100c3bff7 +libICE.6.dylib (10.0.0 - compatibility 10.0.0) <77070DB2-3B37-3833-B36B-BEC1F951AE78> /opt/local/lib/libICE.6.dylib
       0x100c44000 -        0x100c49fff +libffi.5.dylib (6.10.0 - compatibility 6.0.0) <7C64359D-C5FD-35DE-BF46-C3C7C7DEB562> /opt/local/lib/libffi.5.dylib
       0x100c4e000 -        0x100c54ff7 +libltdl.7.dylib (11.0.0 - compatibility 11.0.0) <01887F9F-E14B-3293-9340-B84F6440C570> /opt/local/lib/libltdl.7.dylib
       0x100c58000 -        0x100c5dff7 +libgdbm.4.dylib (5.0.0 - compatibility 5.0.0) <3855703E-AF07-3FF7-A4B6-AA22F4CC5107> /opt/local/lib/libgdbm.4.dylib
       0x100c60000 -        0x100c68ff7 +libintl.8.dylib (10.1.0 - compatibility 10.0.0) <6A83574D-729E-3620-9110-E60286FCC16E> /opt/local/lib/libintl.8.dylib
       0x100c6d000 -        0x100d65ff7 +libiconv.2.dylib (8.1.0 - compatibility 8.0.0) <AAFF2D74-8A41-3C2F-959F-596829FF5892> /opt/local/lib/libiconv.2.dylib
       0x100d72000 -        0x100d86fff +libz.1.dylib (1.2.5 - compatibility 1.0.0) <B6C19687-AAE1-37CB-BA87-0426C2A833E0> /opt/local/lib/libz.1.dylib
       0x100d8a000 -        0x100dc7ff7 +libncurses.5.dylib (5.0.0 - compatibility 5.0.0) <60014346-C481-3C60-A269-47B991D13365> /opt/local/lib/libncurses.5.dylib
       0x100dd6000 -        0x100e90fff +libsqlite3.dylib (9.6.0 - compatibility 9.0.0) <A55D7AE2-8D59-362F-A262-CA6B3BC58FAB> /opt/local/lib/libsqlite3.dylib
       0x100ea1000 -        0x100eb4fff +libsasl2.2.dylib (??? - ???) <9846AC72-1F23-3CC6-BDE3-FED045D8E9F9> /opt/local/lib/libsasl2.2.dylib
    0x7fff5feb6000 -     0x7fff5feeaac7  dyld (195.5 - ???) <4A6E2B28-C7A2-3528-ADB7-4076B9836041> /usr/lib/dyld
    0x7fff8b666000 -     0x7fff8b668fff  libquarantine.dylib (36.0.0 - compatibility 1.0.0) <4C3BFBC7-E592-3939-B376-1C2E2D7C5389> /usr/lib/system/libquarantine.dylib
    0x7fff8c243000 -     0x7fff8c2b8ff7  libc++.1.dylib (19.0.0 - compatibility 1.0.0) <C0EFFF1B-0FEB-3F99-BE54-506B35B555A9> /usr/lib/libc++.1.dylib
    0x7fff8c2be000 -     0x7fff8c300ff7  libcommonCrypto.dylib (55010.0.0 - compatibility 1.0.0) <A5B9778E-11C3-3F61-B740-1F2114E967FB> /usr/lib/system/libcommonCrypto.dylib
    0x7fff8c704000 -     0x7fff8c704fff  libkeymgr.dylib (23.0.0 - compatibility 1.0.0) <61EFED6A-A407-301E-B454-CD18314F0075> /usr/lib/system/libkeymgr.dylib
    0x7fff8c705000 -     0x7fff8c70eff7  libsystem_notify.dylib (80.1.0 - compatibility 1.0.0) <A4D651E3-D1C6-3934-AD49-7A104FD14596> /usr/lib/system/libsystem_notify.dylib
    0x7fff8c70f000 -     0x7fff8c721ff7  libbsm.0.dylib (??? - ???) <349BB16F-75FA-363F-8D98-7A9C3FA90A0D> /usr/lib/libbsm.0.dylib
    0x7fff8cdd4000 -     0x7fff8cdf3fff  libresolv.9.dylib (46.0.0 - compatibility 1.0.0) <33263568-E6F3-359C-A4FA-66AD1300F7D4> /usr/lib/libresolv.9.dylib
    0x7fff8cdf4000 -     0x7fff8ce14fff  libsystem_kernel.dylib (1699.22.73 - compatibility 1.0.0) <69F2F501-72D8-3B3B-8357-F4418B3E1348> /usr/lib/system/libsystem_kernel.dylib
    0x7fff8ce3a000 -     0x7fff8ce57ff7  libxpc.dylib (77.17.0 - compatibility 1.0.0) <72A16104-2F23-3C22-B474-1953F06F9376> /usr/lib/system/libxpc.dylib
    0x7fff8ce91000 -     0x7fff8ce92ff7  libremovefile.dylib (21.0.0 - compatibility 1.0.0) <C6C49FB7-1892-32E4-86B5-25AD165131AA> /usr/lib/system/libremovefile.dylib
    0x7fff8cf37000 -     0x7fff8d014fef  libsystem_c.dylib (763.12.0 - compatibility 1.0.0) <FF69F06E-0904-3C08-A5EF-536FAFFFDC22> /usr/lib/system/libsystem_c.dylib
    0x7fff8d015000 -     0x7fff8d121fff  libcrypto.0.9.8.dylib (44.0.0 - compatibility 0.9.8) <3A8E1F89-5E26-3C8B-B538-81F5D61DBF8A> /usr/lib/libcrypto.0.9.8.dylib
    0x7fff8d24b000 -     0x7fff8d24cfff  libsystem_sandbox.dylib (??? - ???) <8D14139B-B671-35F4-9E5A-023B4C523C38> /usr/lib/system/libsystem_sandbox.dylib
    0x7fff8d5ae000 -     0x7fff8d5affff  libunc.dylib (24.0.0 - compatibility 1.0.0) <C67B3B14-866C-314F-87FF-8025BEC2CAAC> /usr/lib/system/libunc.dylib
    0x7fff8e478000 -     0x7fff8e64cfff  com.apple.CoreFoundation (6.7.1 - 635.15) <FE4A86C2-3599-3CF8-AD1A-822F1FEA820F> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    0x7fff8e8ba000 -     0x7fff8e8c2fff  libsystem_dnssd.dylib (??? - ???) <7749128E-D0C5-3832-861C-BC9913F774FA> /usr/lib/system/libsystem_dnssd.dylib
    0x7fff8e945000 -     0x7fff8e946ff7  libsystem_blocks.dylib (53.0.0 - compatibility 1.0.0) <8BCA214A-8992-34B2-A8B9-B74DEACA1869> /usr/lib/system/libsystem_blocks.dylib
    0x7fff8e959000 -     0x7fff8e95efff  libpam.2.dylib (3.0.0 - compatibility 3.0.0) <D952F17B-200A-3A23-B9B2-7C1F7AC19189> /usr/lib/libpam.2.dylib
    0x7fff8f95d000 -     0x7fff8f98afe7  libSystem.B.dylib (159.1.0 - compatibility 1.0.0) <095FDD3C-3961-3865-A59B-A5B0A4B8B923> /usr/lib/libSystem.B.dylib
    0x7fff8fde9000 -     0x7fff8fdeefff  libcompiler_rt.dylib (6.0.0 - compatibility 1.0.0) <98ECD5F6-E85C-32A5-98CD-8911230CB66A> /usr/lib/system/libcompiler_rt.dylib
    0x7fff90687000 -     0x7fff9068dfff  libmacho.dylib (800.0.0 - compatibility 1.0.0) <D86F63EC-D2BD-32E0-8955-08B5EAFAD2CC> /usr/lib/system/libmacho.dylib
    0x7fff906da000 -     0x7fff906fefff  com.apple.Kerberos (1.0 - 1) <1F826BCE-DA8F-381D-9C4C-A36AA0EA1CB9> /System/Library/Frameworks/Kerberos.framework/Versions/A/Kerberos
    0x7fff906ff000 -     0x7fff90703fff  libdyld.dylib (195.5.0 - compatibility 1.0.0) <F1903B7A-D3FF-3390-909A-B24E09BAD1A5> /usr/lib/system/libdyld.dylib
    0x7fff9076d000 -     0x7fff907a6fe7  libssl.0.9.8.dylib (44.0.0 - compatibility 0.9.8) <79AAEC98-1258-3DA4-B1C0-4120049D390B> /usr/lib/libssl.0.9.8.dylib
    0x7fff90e5a000 -     0x7fff9105cfff  libicucore.A.dylib (46.1.0 - compatibility 1.0.0) <38CD6ED3-C8E4-3CCD-89AC-9C3198803101> /usr/lib/libicucore.A.dylib
    0x7fff910be000 -     0x7fff910c8ff7  liblaunch.dylib (392.18.0 - compatibility 1.0.0) <39EF04F2-7F0C-3435-B785-BF283727FFBD> /usr/lib/system/liblaunch.dylib
    0x7fff91160000 -     0x7fff91165ff7  libsystem_network.dylib (??? - ???) <5DE7024E-1D2D-34A2-80F4-08326331A75B> /usr/lib/system/libsystem_network.dylib
    0x7fff911bc000 -     0x7fff91494ff7  com.apple.security (7.0 - 55010) <93713FF4-FE86-3B4C-8150-5FCC7F3320C8> /System/Library/Frameworks/Security.framework/Versions/A/Security
    0x7fff91aec000 -     0x7fff91af0fff  libmathCommon.A.dylib (2026.0.0 - compatibility 1.0.0) <FF83AFF7-42B2-306E-90AF-D539C51A4542> /usr/lib/system/libmathCommon.A.dylib
    0x7fff91af9000 -     0x7fff91b34fff  com.apple.LDAPFramework (3.0 - 120.1) <0C23534F-A8E7-3144-B2B2-50F9875101E2> /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP
    0x7fff91b7d000 -     0x7fff91b7efff  libdnsinfo.dylib (395.6.0 - compatibility 1.0.0) <718A135F-6349-354A-85D5-430B128EFD57> /usr/lib/system/libdnsinfo.dylib
    0x7fff9219a000 -     0x7fff9220dfff  libstdc++.6.dylib (52.0.0 - compatibility 7.0.0) <6BDD43E4-A4B1-379E-9ED5-8C713653DFF2> /usr/lib/libstdc++.6.dylib
    0x7fff922a1000 -     0x7fff92326ff7  com.apple.Heimdal (2.1 - 2.0) <C92E327E-CB5F-3C9B-92B0-F1680095C8A3> /System/Library/PrivateFrameworks/Heimdal.framework/Versions/A/Heimdal
    0x7fff92327000 -     0x7fff92332ff7  libc++abi.dylib (14.0.0 - compatibility 1.0.0) <8FF3D766-D678-36F6-84AC-423C878E6D14> /usr/lib/libc++abi.dylib
    0x7fff926e5000 -     0x7fff92720ff7  libsystem_info.dylib (??? - ???) <9C8C2DCB-96DB-3471-9DCE-ADCC26BE2DD4> /usr/lib/system/libsystem_info.dylib
    0x7fff92cc5000 -     0x7fff92ccafff  libcache.dylib (47.0.0 - compatibility 1.0.0) <B7757E2E-5A7D-362E-AB71-785FE79E1527> /usr/lib/system/libcache.dylib
    0x7fff938a9000 -     0x7fff938aafff  libDiagnosticMessagesClient.dylib (??? - ???) <3DCF577B-F126-302B-BCE2-4DB9A95B8598> /usr/lib/libDiagnosticMessagesClient.dylib
    0x7fff945d8000 -     0x7fff94626fff  libauto.dylib (??? - ???) <D8AC8458-DDD0-3939-8B96-B6CED81613EF> /usr/lib/libauto.dylib
    0x7fff94627000 -     0x7fff9462efff  libcopyfile.dylib (85.1.0 - compatibility 1.0.0) <172B1985-F24A-34E9-8D8B-A2403C9A0399> /usr/lib/system/libcopyfile.dylib
    0x7fff95007000 -     0x7fff9500dff7  libunwind.dylib (30.0.0 - compatibility 1.0.0) <1E9C6C8C-CBE8-3F4B-A5B5-E03E3AB53231> /usr/lib/system/libunwind.dylib
    0x7fff95a0c000 -     0x7fff95a1afff  libdispatch.dylib (187.7.0 - compatibility 1.0.0) <712AAEAC-AD90-37F7-B71F-293FF8AE8723> /usr/lib/system/libdispatch.dylib
    0x7fff969bf000 -     0x7fff96aa3def  libobjc.A.dylib (228.0.0 - compatibility 1.0.0) <C5F2392D-B481-3A9D-91BE-3D039FFF4DEC> /usr/lib/libobjc.A.dylib
    0x7fff975b3000 -     0x7fff975b5fff  com.apple.TrustEvaluationAgent (2.0 - 1) <1F31CAFF-C1C6-33D3-94E9-11B721761DDF> /System/Library/PrivateFrameworks/TrustEvaluationAgent.framework/Versions/A/TrustEvaluationAgent

Model: Macmini2,1, BootROM MM21.009A.B00, 2 processors, Intel Core 2 Duo, 1.83 GHz, 4 GB, SMC 1.19f2
Graphics: Intel GMA 950, GMA 950, Built-In, spdisplays_integrated_vram
Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 667 MHz, 0x7F7F7F94FFFFFFFF, 0x393731353539410000000000000000000000
Memory Module: BANK 1/DIMM1, 2 GB, DDR2 SDRAM, 667 MHz, 0x7F7F7F94FFFFFFFF, 0x393731353539410000000000000000000000
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x86), Atheros 5424: 2.1.14.9
Bluetooth: Version 4.0.1f4, 2 service, 11 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Network Service: Nokia N9 2, Ethernet, en4
Serial ATA Device: ST9750420AS, 750.16 GB
Parallel ATA Device: MATSHITACD-RW  CW-8124
USB Device: USB2.0 Hub, 0x05e3  (Genesys Logic, Inc.), 0x0608, 0xfd500000 / 3
USB Device: Nokia N9, 0x0421  (Nokia Corporation), 0x051a, 0xfd510000 / 2
USB Device: Android Phone, 0x0bb4  (HTC Corporation), 0x0ff9, 0xfd530000 / 4
USB Device: USB2.0 Hub, 0x05e3  (Genesys Logic, Inc.), 0x0608, 0xfd540000 / 6
USB Device: hub_device, 0x0557  (ATEN International Co. Ltd.), 0x7000, 0x5d200000 / 2
USB Device: Trackball, 0x046d  (Logitech Inc.), 0xc404, 0x5d240000 / 4
USB Device: ThinkPad USB Keyboard with TrackPoint, 0x17ef  (Lenovo), 0x6009, 0x5d210000 / 3
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8205, 0x7d100000 / 2
USB Device: IR Receiver, apple_vendor_id, 0x8240, 0x7d200000 / 3
FireWire Device: WD10TPVT-00HT5T1, DMI, 400mbit_speed

comment:2 follow-up: ↓ 4 Changed 2 years ago by kato23@…

The error is from the buggy pattern matching of a case command in cyrus-sasl-2.1.23/config/ltconfig where (on my machine) case "$host_os" in ... darwin[15]* | rhapsody*) unfortunately matches i386-apple-darwin10.8.0 . The matching expression of the case command has to be altered to darwin[15].* | rhapsody*) to prevent this (see http://en.wikipedia.org/wiki/Darwin_(operating_system) for a list of Darwin kernel version numbers).

The same faulty pattern matching code can be found in cyrus-sasl-2.1.23/saslauthd/config/ltconfig although it does not seem to cause any error there.

To replace your wrongly versioned libsasl2.dylib with a correctly versioned one try the following:

sudo port -f uninstall cyrus-sasl2
sudo port clean --all cyrus-sasl2
sudo port extract cyrus-sasl2
cd "$(port dir cyrus-sasl2)"/work/cyrus-sasl-2.1.23

/bin/sh config/config.guess  # i386-apple-darwin10.8.0
sudo /bin/sh -c 'config/ltconfig config/ltmain.sh'

printf '%s\n' H '/\(darwin\[15\]\)/s//\1./g' wq | sudo ed -s config/ltconfig
printf '%s\n' H '/\(darwin\[15\]\)/s//\1./g' wq | sudo ed -s saslauthd/config/ltconfig

sudo port -f -s install cyrus-sasl2

otool -L /opt/local/lib/libsasl2.dylib
# /opt/local/lib/libsasl2.dylib:
#         /opt/local/lib/libsasl2.2.dylib (compatibility version 3.0.0, current version 3.23.0)
#         /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.2.11)
#         /usr/lib/libresolv.9.dylib (compatibility version 1.0.0, current version 41.1.0)

# check for further wrongly versioned dylibs
otool -L /opt/local/lib/*.dylib | 
   grep 'compatibility version 0.0.0, current version 0.0.0' | sort -u | nl

comment:3 Changed 2 years ago by macsforever2000@…

  • Cc landonf@… added
  • Owner changed from macports-tickets@… to jmpp@…
  • Port set to cyrus-sasl2
  • Description modified (diff)

comment:4 in reply to: ↑ 2 Changed 2 years ago by kato23@…

Replying to kato23@…:

The error is from the buggy pattern matching of a case command in cyrus-sasl-2.1.23/config/ltconfig where (on my machine) case "$host_os" in ... darwin[15]* | rhapsody*) unfortunately matches i386-apple-darwin10.8.0 .


Should read:

The error is from the buggy pattern matching of a case command in cyrus-sasl-2.1.23/config/ltconfig where (on my machine) case "$host_os" in ... darwin[15]* | rhapsody*) unfortunately matches darwin10.8.0 (as derived from i386-apple-darwin10.8.0) .


# In cyrus-sasl-2.1.23/config/ltconfig we have the following commands (in an abridged form) ...
echo $ac_n "checking host system type""... $ac_c" 1>&6
host_alias=`$SHELL $ac_config_guess`
host=`$SHELL $ac_config_sub $host_alias`
echo "$ac_t$host" 1>&6
...
host_os=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'`

# ... which can be roughly reproduced in the shell using ...
cd "$(port dir cyrus-sasl2)"/work/cyrus-sasl-2.1.23
host_alias=`/bin/sh config/config.guess`
host=`/bin/sh config/config.sub $host_alias`
host_os=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'`

printf '%s\n' "host: $host" "host_os: $host_os"
# host: i386-apple-darwin10.8.0
# host_os: darwin10.8.0

comment:5 Changed 22 months ago by jmr@…

  • Status changed from new to closed
  • Resolution set to fixed

This won't actually cause any errors unless you do something like set DYLD_LIBRARY_PATH incorrectly, but sure, the lib version is wrong. Fixed in r94807.

Note: See TracTickets for help on using tickets.