Opened 9 years ago

Closed 9 years ago

#32398 closed defect (duplicate)

gobject-introspection @1.30.0 +SyntaxError: invalid syntax when python is version 3.x

Reported by: nhojpatrick (John Patrick) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt), singingwolfboy@…
Port: gobject-introspection

Description

Just did an upgrade and got the following error. Tried it again and captured the output in the console.log file, and attached the main.log.

Attachments (2)

gobject-introspection.console.log (1.3 KB) - added by nhojpatrick (John Patrick) 9 years ago.
gobject-introspection.main.log (14.3 KB) - added by nhojpatrick (John Patrick) 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by nhojpatrick (John Patrick)

Changed 9 years ago by nhojpatrick (John Patrick)

comment:1 Changed 9 years ago by nhojpatrick (John Patrick)

Cc: nhoj.patrick@… added

Cc Me!

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… singingwolfboy@… added; nhoj.patrick@… removed
Resolution: duplicate
Status: newclosed
Summary: gobject-introspection @1.30.0 +SyntaxError: invalid syntaxgobject-introspection @1.30.0 +SyntaxError: invalid syntax when python is version 3.x

Looks like you've selected python 3.1, and gobject-introspection doesn't like that. Try installing and selecting python 2.7. Then clean and try installing gobject-introspection again. Duplicate of #28479.

Note: See TracTickets for help on using tickets.