Opened 9 years ago

Closed 9 years ago

#32406 closed defect (fixed)

kdevplatform: crashes when compiling with svn plugin

Reported by: benjamin@… Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: kdevplatform kdevelop

Description (last modified by ryandesign (Ryan Schmidt))

Steps to reproduce:

  • project -> new from template...
  • c++ no gui / simple cmake based c++...
  • project name test
  • no version control
  • Finish
  • OK

Below is the output of kdevelop:

kdevelop(59241)/KSharedDataCache ensureFileAllocated: This system misses support for posix_fallocate() -- ensure this partition has room for at least 10547296 bytes. 
kdevelop(59241)/KSharedDataCache: Unable to find an appropriate lock to guard the shared cache.  This *should* be essentially impossible. :( 
kdevelop(59241)/KSharedDataCache: Unable to perform initial setup, this system probably does not really support process-shared pthreads or semaphores, even though it claims otherwise. 
kdevelop(59241)/KSharedDataCache: Unable to unmap shared memory segment 0x10d08f000 
WARNING: deleting stale lockfile /Users/bpiwowar/.kdevduchain/{c65e1ea8-e78e-4c13-aeb6-9f73fbf0a7ca}/0/lock
kdevelop(59241)/kdevplatform (language) KDevelop::ItemRepositoryRegistry::open: version-hint not found, seems to be an old version 
kdevelop(59241)/kdevplatform (language) KDevelop::ItemRepositoryRegistry::open: "The data-repository at /Users/bpiwowar/.kdevduchain/{c65e1ea8-e78e-4c13-aeb6-9f73fbf0a7ca}/0 has to be cleared." 
kdevelop(59241)/kdevplatform (shell) KDevelop::PluginController::loadPluginInternal: Loading plugin ' "kdevkonsoleview" ' failed, KPluginLoader reported error: ' 
"No service matching the requirements was found" ' 
QMenu: No OSMenuRef created for popup menu
QMenu: No OSMenuRef created for popup menu
kdevelop(59241): couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol 'man'.
" 
kdevelop(59241) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf! 
bzDecompress returned 4 
KBzip2Filter::uncompress 1 
bzDecompress returned 4 
KBzip2Filter::uncompress 1 
bzDecompress returned 4 
KBzip2Filter::uncompress 1 
bzDecompress returned 4 
KBzip2Filter::uncompress 1 
bzDecompress returned 4 
KBzip2Filter::uncompress 1 
kdevelop(59241)/kdevplatform (shell) KDevelop::PluginController::loadPluginInternal: Unable to find a plugin named ' "" '! 
QKqueueFileSystemWatcherEngine: error during kevent wait: Bad file descriptor
Unable to start Dr. Konqi

Change History (5)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to nicos@…
Port: kdevelop added
Summary: Kdevelop crashes when importing/creating projectskdevelop crashes when importing/creating projects

Please remember to use WikiFormatting and to preview before submitting, to fill in the Port field, and to Cc the maintainer of that port.

comment:2 Changed 9 years ago by NicosPavlov

I did take a look at the problem, but it seems slightly more complicated than what I thought at the beginning. Similar debug messages appear on a working install (Kubuntu, 11.04), where the project can nevertheless be created. Identifying the problem will thus take more analysis.

comment:3 Changed 9 years ago by david@…

I had the same problem and after running it in gdb I could see it was crashing doing svn stuff. So I disabled the svn plugin and it now works. Maybe svn library mismatch? doesn't appear to be using the osx subversion library but maybe it compiled against it?

  (gdb) bt
  #0  0x000000010f0f2346 in svn_wc__get_info ()
  #1  0x000000010f017a70 in svn_client_info3 ()
  #2  0x000000010f0101c3 in svn_client_info ()
  #3  0x000000010ef9856e in svn::Client::info ()
  #4  0x000000010ef82a83 in SvnInternalInfoJob::run ()
  #5  0x0000000100aea7ed in ThreadWeaver::JobRunHelper::runTheJob ()
  #6  0x0000000100aeaa34 in ThreadWeaver::Job::execute ()
  #7  0x0000000100ae9a65 in ThreadWeaver::ThreadRunHelper::run ()
  #8  0x0000000100ae9dee in ThreadWeaver::Thread::run ()
  #9  0x00000001023b73be in QThreadPrivate::start ()
  #10 0x00007fff8eddd8bf in _pthread_start ()
  #11 0x00007fff8ede0b75 in thread_start ()

comment:4 Changed 9 years ago by NicosPavlov

Port: kdevplatform added
Status: newassigned
Summary: kdevelop crashes when importing/creating projectskdevplatform: crashes when compiling with svn plugin

Thanks a lot for the input. I can indeed reproduce this behaviour. It seems however that the compilation correctly links to the macports version of subversion, as shown from the output of the configuration step:

-- Found subversion client lib: /opt/local/lib/libsvn_client-1.dylib
-- Found subversion repository lib: /opt/local/lib/libsvn_repos-1.dylib
-- Found subversion fs lib: /opt/local/lib/libsvn_fs-1.dylib
-- Found subversion subr lib: /opt/local/lib/libsvn_subr-1.dylib
-- Found subversion wc lib: /opt/local/lib/libsvn_wc-1.dylib
-- Found subversion ra lib: /opt/local/lib/libsvn_ra-1.dylib

In order to have a functioning version, I disabled the svn plugin in the Portfile in r89436. It could then be added as a variant if the problem can be solved.

comment:5 Changed 9 years ago by NicosPavlov

Resolution: fixed
Status: assignedclosed

This bug seemed to be due to a misuse of subversion version 1.7 https://bugs.kde.org/show_bug.cgi?id=284061, which is solved with kdevelop 4.3.0, committed in r90780.

Note: See TracTickets for help on using tickets.