Opened 9 years ago

Closed 9 years ago

#32423 closed defect (duplicate)

gnome-doc-utils @0.20.6 configure error with perl5 +perl5_8/10/14

Reported by: larryv (Lawrence Velázquez) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: haspatch Cc: dbevans (David B. Evans)
Port: gnome-doc-utils

Description

The configure phase for gnome-doc-utils fails when perl5 +perl5_14 is installed, and I assume any other variant that isn’t +perl5_12.

Since intltool requires perl5.12 and 5.12-specific module ports, the gnome-doc-utils configure script fails to find them if the default Perl is not 5.12. (See attached portion of the build log.)

The patch corrects this by explicitly providing the path to the perl5.12 executable. This would have to be updated when intltool is updated to perl5.14.

Attachments (2)

Portfile-gnome-doc-utils.diff (634 bytes) - added by larryv (Lawrence Velázquez) 9 years ago.
Patch to use perl5.12 explicitly
gnome-doc-utils.log (2.0 KB) - added by larryv (Lawrence Velázquez) 9 years ago.
Tail of build log when perl5 +perl5_14 is installed

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by larryv (Lawrence Velázquez)

Patch to use perl5.12 explicitly

Changed 9 years ago by larryv (Lawrence Velázquez)

Attachment: gnome-doc-utils.log added

Tail of build log when perl5 +perl5_14 is installed

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: openmaintainer@… larry.velazquez@… removed
Resolution: duplicate
Status: newclosed

Duplicate of #28565.

Note: See TracTickets for help on using tickets.