Opened 9 years ago

Closed 9 years ago

#32435 closed defect (invalid)

Port file not available

Reported by: hfollmann@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: mww@…, jyrkiwahlstedt
Port: postgresql90

Description (last modified by neverpanic (Clemens Lang))

The port file postgresql90-9.0.6_... is missing at http://packages.macports.org/postgresql90/

--->  Computing dependencies for postgresql90
--->  Fetching archive for postgresql90
--->  Attempting to fetch postgresql90-9.0.6_0+perl+python.darwin_11.x86_64.tbz2 from http://packages.macports.org/postgresql90
--->  Fetching postgresql90
--->  Verifying checksum(s) for postgresql90
Error: Checksum (md5) mismatch for postgresql-9.0.6.tar.bz2
Error: Checksum (sha1) mismatch for postgresql-9.0.6.tar.bz2
Error: Checksum (rmd160) mismatch for postgresql-9.0.6.tar.bz2

Change History (1)

comment:1 Changed 9 years ago by neverpanic (Clemens Lang)

Cc: mww@… jwa@… added
Description: modified (diff)
Resolution: invalid
Status: newclosed

Please use WikiFormatting and remember to Cc the maintainer when reporting problems as described in the Ticket Guidelines prominently linked from the new ticket page.

MacPorts recently started fetching prebuilt binary packages form packages.macports.org, which fails if there are none. This might happen for licensing reasons and currently always happens on Lion, because we're not building packages for Lion yet. This is what the line "---> Attempting to fetch" is about.

If this step fails, port continues to download sources and build from source like it did before, which apparently fails for you, because your download is corrupted. I can not reproduce your problem and successfully fetched the source tarball from ftp7.de.postgresql.org. Try running port with -d to see where your MacPorts is fetching from.

Checksum problems are a frequently asked question, have a look at FAQ and MisbehavingServers.

I have verified all mirrors we have listed for the postgresql90 port and they either server a correct error message, don't work at all or serve the correct file.

Note: See TracTickets for help on using tickets.