Opened 9 years ago

Closed 8 years ago

#32527 closed defect (worksforme)

libgnomeui build failure: loaders.cache: no such file or directory

Reported by: robertkuhar@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: libgnomeui gdk-pixbuf2

Description

I am trying to get Meld onto my OS X 10.6.8 box using MacPorts 2.0.3 and am not having success.

bobk-mbp:build bobk$ sudo port clean --work meld
Password:
--->  Cleaning meld
bobk-mbp:build bobk$ sudo port install meld
Password:
--->  Computing dependencies for meld
--->  Dependencies to be installed: py26-gnome libgnomeui py26-gtk py26-cairo py26-numpy fftw-3 py26-nose py26-distribute python26 py26-py py26-gobject py26-orbit
--->  Building libgnomeui
Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Failed to install libgnomeui
Log for libgnomeui is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/main.log
Error: The following dependencies were not installed: py26-gnome libgnomeui py26-gtk py26-cairo py26-numpy fftw-3 py26-nose py26-distribute python26 py26-py py26-gobject py26-orbit
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

When I look at /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/main.log it has a line like...

:info:build Warning: the following items did not execute (for libgnomeui): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:error:build Failed to install libgnomeui
:debug:build couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing
"open [file join $dir tclIndex]"
:notice:build Log for libgnomeui is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/main.log

...and that file is indeed missing on my system. Is this a MacPort bug or failed configuration on my system?

There is an older XCode on this Mac at Version 3.2.6 (1761)

Attachments (1)

main.log (142.2 KB) - added by robertkuhar@… 9 years ago.
main.log following clean suggestion

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Port: libgnomeui added
Summary: Unable to install Meld via MacPorts 2.0.3 on OSX 10.6.8libgnomeui build failure

I don't see any error message in that log that I can do anything with.

The tclIndex error message you mentioned above (which does not appear in the log) is spurious and is never the cause of a problem.

Please clean the affected port and try again and attach the new main.log.

sudo port clean libgnomeui
sudo port install libgnomeui

comment:2 in reply to:  1 Changed 9 years ago by robertkuhar@…

Replying to ryandesign@…:

I don't see any error message in that log that I can do anything with.

The tclIndex error message you mentioned above (which does not appear in the log) is spurious and is never the cause of a problem.

Please clean the affected port and try again and attach the new main.log.

sudo port clean libgnomeui
sudo port install libgnomeui

I have executed those steps and the result is essentially the same. Here is the console output, I have attached the main.log.

bobk-mbp:build bobk$ sudo port clean libgnomeui
Password:
--->  Cleaning libgnomeui
bobk-mbp:build bobk$ sudo port clean meld
--->  Cleaning meld
bobk-mbp:build bobk$ sudo port install libgnomeui
--->  Computing dependencies for libgnomeui
--->  Fetching archive for libgnomeui
--->  Attempting to fetch libgnomeui-2.24.5_1.darwin_10.x86_64.tbz2 from http://packages.macports.org/libgnomeui
--->  Fetching libgnomeui
--->  Verifying checksum(s) for libgnomeui
--->  Extracting libgnomeui
--->  Configuring libgnomeui
--->  Building libgnomeui
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for libgnomeui is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
bobk-mbp:build bobk$ 

Changed 9 years ago by robertkuhar@…

Attachment: main.log added

main.log following clean suggestion

comment:3 Changed 9 years ago by robertkuhar@…

This main.log is indeed different. It is not complaining about missing tclIndex, but it does have failures that are equally mysterious to me...

...
:info:build failed to load "./stock_attach.png": Couldn't recognize the image file format for file './stock_attach.png'
:info:build make[4]: *** [gnome-stock-pixbufs.h] Error 1
:info:build make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/work/libgnomeui-2.24.5/libgnomeui/pixmaps'
:info:build make[3]: *** [all-recursive] Error 1
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/work/libgnomeui-2.24.5/libgnomeui'
:info:build make[2]: *** [all] Error 2
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/work/libgnomeui-2.24.5/libgnomeui'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/work/libgnomeui-2.24.5'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/work/libgnomeui-2.24.5'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gnome_libgnomeui/libgnomeui/work/libgnomeui-2.24.5" && /usr/bin/make -j4 -w all " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
...

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

Summary: libgnomeui build failurelibgnomeui build failure: loaders.cache: no such file or directory

Ok so the relevant error seems to be:

:info:build (process:39463): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/opt/local/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory
:info:build failed to load "./stock_attach.png": Couldn't recognize the image file format for file './stock_attach.png'
:info:build make[4]: *** [gnome-stock-pixbufs.h] Error 1

I assume something in another port was supposed to make that loaders.cache but didn't, and now as a result libgnomeui can't figure out what format its images are.

comment:5 Changed 9 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to devans@…
Port: gdk-pixbuf2 added

Is this still a problem with current versions?

comment:6 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

No response; presumed fixed.

Note: See TracTickets for help on using tickets.