Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#32537 closed defect (worksforme)

xorg-libX11 +universal is not universal

Reported by: Russell-Jones-OxPhys (Russell Jones) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia), ryandesign (Ryan Schmidt)
Port: xorg-libX11

Description

The error is that /opt/local/lib/libX11.dylib does not contain i386 code. According to file, this is correct, and it is x86_64 only. However, port installed lists it as being built +universal.

Log attached.

Attachments (1)

pango-main.log (129.2 KB) - added by Russell-Jones-OxPhys (Russell Jones) 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by Russell-Jones-OxPhys (Russell Jones)

Attachment: pango-main.log added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Port: xorg-libX11 added; pango removed
Summary: pango 1.28.4_2 fails to build +universal on Lionxorg-libX11 +universal is not universal

Then I need to see a main.log of xorg-libX11 not pango. If the log was deleted (which MacPorts does by default after install), try rebuilding xorg-libX11 ("sudo port -n upgrade --force xorg-libX11"). Does that result in a universal xorg-libX11, and then a successful pango installation?

comment:2 Changed 9 years ago by Russell-Jones-OxPhys (Russell Jones)

I used port -f uninstall xorg-libX11 then port install xorg-libX11. I then got an error on libXau, libxcb (IIRC) and possibly a couple of others, then things started working. gdk-pixbuf2 ( #32536 ) started building, too. I guess the files were somehow replaced with 64-bit only versions without the port registry being updated. I've removed some port -f install lines I had in my build script, which were to replace files outside of /opt (a bit lazy, I know). Could they have been the cause if they were built -universal (I have +universal in my variants.conf)

comment:3 Changed 9 years ago by Russell-Jones-OxPhys (Russell Jones)

possibly a couple of others, then things started working.

->

possibly a couple of others, did the same for those iteratively, then things started working.

comment:4 in reply to:  2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

Replying to russell.jones@…:

I guess the files were somehow replaced with 64-bit only versions without the port registry being updated.

I guess so. It's hard for me to follow how that might have happened but if you have things working now then we'll hope they'll stay that way.

comment:5 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Is +universal set in your variants.conf? Setting and unsetting that can be a bit dangerous.

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

It shouldn't be dangerous; it should work correctly.

Note: See TracTickets for help on using tickets.