Opened 9 years ago

Closed 8 years ago

#32557 closed defect (invalid)

building atlas crashes OSX

Reported by: macporter90210@… Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: atlas

Description

While building the atlas port, the machine crashed. Opening up console after restarting the machine showed me two crash reports for xprobe_3dnow some time before the machine crash. I attach the various crash reports.

Attachments (4)

main.log (5.5 MB) - added by macporter90210@… 9 years ago.
main.log for the atlas port build in /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/atlas/main.log
xprobe_3dnow_2011-12-15-132033_localhost.crash (2.3 KB) - added by macporter90210@… 9 years ago.
xprobe_gas_x8632_2011-12-15-132033_localhost.crash (2.3 KB) - added by macporter90210@… 9 years ago.
xprobe_3dnow_2011-12-15-132044_localhost.crash (2.0 KB) - added by macporter90210@… 9 years ago.

Change History (13)

Changed 9 years ago by macporter90210@…

Attachment: main.log added

main.log for the atlas port build in /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/atlas/main.log

Changed 9 years ago by macporter90210@…

Changed 9 years ago by macporter90210@…

Changed 9 years ago by macporter90210@…

comment:1 Changed 9 years ago by macporter90210@…

Note: the crash report files *_localhost.crash are located in /Library/Logs/DiagnosticReports/ Someone should probably also report this to Apple. Also, stuff like http://communities.intel.com/thread/4968 may be relevant.

comment:3 Changed 9 years ago by Veence (Vincent)

Resolution: invalid
Status: newclosed

This crashes are normal and part of Atlas configure process to determine on which processor it runs. It could do that with a CPUID instruction, but, for whatever reason, it does not.

comment:4 Changed 9 years ago by macporter90210@…

Resolution: invalid
Status: closedreopened

How can a machine crash be a normal part of a build process? How do I finally install ATLAS since it will keep crashing?

comment:5 Changed 9 years ago by macporter90210@…

To clarify, the problem is that after the crash, many of the commands do not work on terminal, so the machine is unusable and I have to restart the computer. Why does that happen?

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

It should not be possible for a port install, no matter how bad it fails, to cause your computer to require a restart. Are you sure that just closing the Terminal window and opening a new one would not have solved it? What exactly do you mean when you say "the machine crashed"?

comment:7 in reply to:  6 Changed 9 years ago by macporter90210@…

I think I tried another terminal window. Besides, I tried to log out and log back in. I couldn't even do that, so I had to power the machine down.

comment:8 Changed 8 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to vince@…
Status: reopenednew

comment:9 Changed 8 years ago by Veence (Vincent)

Resolution: invalid
Status: newclosed

This crashes are normal, they are part of the auto-detection system Atlas uses to know what kind of assembler it can use. It happens to everybody who builds the port. This is irrelevant to any OS crash.

Note: See TracTickets for help on using tickets.