Opened 10 years ago

Closed 9 years ago

#32647 closed defect (fixed)

Lilypond @2.14.2 configure failure, claims to requires clang 3.4

Reported by: tommy.rushton@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version:
Keywords: clang Cc: ryandesign (Ryan Schmidt), g5pw (Aljaž Srebrnič), macports@…
Port: lilypond

Description

Attempting to install under OS X 10.7.2 with Xcode 4.2.1. lilypond requires clang in order to build, but this is not listed as a dependency, nor does the required verison appear to be available.

:info:configure ERROR: Please install required programs:  /Developer/usr/bin/clang >= 3.4 (installed: 3.0) /Developer/usr/bin/clang++ >= 3.4 (installed: 3.0)

Attachments (1)

main.log (181.8 KB) - added by tommy.rushton@… 10 years ago.
Log for lilypond, detailing failure.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by tommy.rushton@…

Attachment: main.log added

Log for lilypond, detailing failure.

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Keywords: clang added
Owner: changed from macports-tickets@… to snc@…
Summary: Lilypond @2.14.2 configure failure, requires clangLilypond @2.14.2 configure failure, claims to requires clang 3.4

In MacPorts we generally do not specify dependencies on compilers, unless it is an unusual one. Users are expected to have Xcode installed, which provides the needed compilers.

As of Xcode 4.2, MacPorts uses Xcode's clang by default. Xcode includes a pre-release version of clang 3.0. The final version of clang 3.0 was just released December 1, 2011. This hypothetical clang 3.4 the error message refers to probably won't be conceived for several more years.

The problem is they're assuming the compiler is gcc, and are trying to verify you're using at least gcc 3.4 (a very old version).

This is upstream bug 2011, which claims the issue is resolved in a newer upstream version of lilypond.

comment:2 in reply to:  1 Changed 10 years ago by tommy.rushton@…

I attempted applying the patch as per http://codereview.appspot.com/5440043 but to no avail; yields the same error. Am I overlooking something simple here? Any help much appreciated.

comment:3 Changed 10 years ago by nerdling (Jeremy Lavergne)

Status: newassigned

Here's the patch you can apply. I'll be trying this evening.

comment:4 Changed 10 years ago by nerdling (Jeremy Lavergne)

Cc: ryandesign@… added
Version: 2.0.3

The upstream patch, after successfully applying it, does not work for me with clang 3.0.

comment:5 Changed 10 years ago by nerdling (Jeremy Lavergne)

Oh, likely needs autoconf.

comment:6 Changed 10 years ago by nerdling (Jeremy Lavergne)

But can't do that since there are missing templates.

comment:7 Changed 10 years ago by g5pw (Aljaž Srebrnič)

Cc: a2piratesoft@… added

Cc Me!

comment:8 Changed 10 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:9 Changed 10 years ago by alvin.armea@…

A temporary workaround is to compile and install lilypond with gcc by

sudo port install lilypond configure.compiler=llvm-gcc-4.2

No patches required.

comment:10 Changed 10 years ago by nerdling (Jeremy Lavergne)

Without the patch I'm able to build with LLVM as well, so I'm committing it as such: r90801.

comment:11 Changed 9 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.