Opened 6 years ago

Closed 6 years ago

#32649 closed defect (fixed)

erlang R15B build fails on 10.5.8 ppc (powerpc-apple-darwin9.8.0)

Reported by: bK4gYuRo Owned by: bfulgham@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: haspatch Cc: ryandesign (Ryan Schmidt)
Port: erlang

Description (last modified by mf2k (Frank Schima))

The error is this:

:info:build powerpc-apple-darwin9.8.0/opt/smp/hipe_ppc_bifs.S:457:Parameter syntax error (parameter 3)

Full log is attached.

Attachments (3)

main.log (338.2 KB) - added by bK4gYuRo 6 years ago.
Portfile.diff (482 bytes) - added by ryandesign (Ryan Schmidt) 6 years ago.
proposed patch
patch-erts_emulator_hipe_hipe_ppc_bifs.m4.diff (1.8 KB) - added by ryandesign (Ryan Schmidt) 6 years ago.
proposed patch

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by bK4gYuRo

Attachment: main.log added

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to bfulgham@…
Port: R15B_1 removed

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Keywords: haspatch added

Confirmed on my Leopard G4. The problem seems to be that some of the lines they've added to the assembler source files in R15B contain comments, like this:

	STORE	r4, P_ARG0(r3)		# Store BIF__ARGS in def_arg_reg[]

And the assembler doesn't like those comments. Another report of this kind of problem is here. There, they fixed the problem by removing the comments, but I think the problem is just that "#" is not a valid start-of-comment character in this context, at least not for the assembler that's on PowerPC Macs. I Googled examples of PowerPC assembly code, and they use ";" as the start-of-comment character. Here's a patch that makes this change, and now it builds for me. I haven't tested on Tiger yet.

Changed 6 years ago by ryandesign (Ryan Schmidt)

Attachment: Portfile.diff added

proposed patch

Changed 6 years ago by ryandesign (Ryan Schmidt)

proposed patch

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

comment:4 Changed 6 years ago by smbmacportstrac@…

I just verified that this patch fixes the compile problem. Please commit this fix. It is still needed for 10.5.8 ppc. Thank you.

comment:5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Committed in r96434.

Someone should still report this problem to the developers of erlang.

Note: See TracTickets for help on using tickets.