Opened 8 years ago

Closed 8 years ago

#32663 closed defect (fixed)

linuxdoc-tools: expand: stdin: Illegal byte sequence

Reported by: silverdr@… Owned by: mklein-de (Michael Klein)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: linuxdoc-tools

Description (last modified by ryandesign (Ryan Schmidt))

Whenever trying to install linuxdoc-tools port I receive errors on both 10.5/PPC and 10.6/intel machines. Running the port with -d option gives the following:

Processing file ./guide.sgml
- Building lyx docs
Processing file ./guide.sgml
expand: stdin: Illegal byte sequence
LinuxdocTools::process_file: Error running sgmlsasp /tmp/ldt.N5jBuF0nl6/linuxdoc-tools/mappings/lyx/mapping < /tmp/ldt.N5jBuF0nl6/linuxdoc-tools.eYx2U1JxY6/sgmltmp.guide.2 |
      expand -t 8 > /tmp/ldt.N5jBuF0nl6/linuxdoc-tools.eYx2U1JxY6/sgmltmp.guide.3. Aborting ...
make: *** [install] Error 2
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_linuxdoc-tools/linuxdoc-tools/work/linuxdoc-tools-0.9.66'
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_linuxdoc-tools/linuxdoc-tools/work/linuxdoc-tools-0.9.66" && /usr/bin/make -w install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_linuxdoc-tools/linuxdoc-tools/work/destroot " returned error 2
Error: Target org.macports.destroot returned: shell command failed (see log for details)
DEBUG: Backtrace: shell command failed (see log for details)
    while executing
"command_exec destroot"
    (procedure "portdestroot::destroot_main" line 2)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for linuxdoc-tools): org.macports.activate org.macports.destroot org.macports.install
Log for linuxdoc-tools is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_linuxdoc-tools/linuxdoc-tools/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (3)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to michael.klein@…
Summary: Linuxdoc-Tools fails upon staging into destrootlinuxdoc-tools: expand: stdin: Illegal byte sequence

Confirmed.

A newer unstable version 0.9.67 is available, but updating to that doesn't change the error message.

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

The invalid byte sequence in question appears to be the one-half fraction character. The stream expand is processing appears to be in ISO-8859-1 encoding but it is presumably expecting UTF-8 encoding. I don't know why the expand command should care at all what the encoding is, since all expand does is translate whitespace, but apparently it does care.

The same error was reported in #28819 but was closed as invalid at the time because the user had manually augmented the MacPorts environment to set the encoding, which is unsupported. However, these days, MacPorts automatically sets the encoding to UTF-8, thus this is now a real problem we need to solve.

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Fixed incorrectly in r88292 and correctly in r88293.

Note: See TracTickets for help on using tickets.