Opened 8 years ago

Closed 4 years ago

#32664 closed defect (wontfix)

php5-unit @3.5.15: Failed opening required 'PHP/CodeCoverage/Filter.php'

Reported by: polkehn@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: php5-unit

Description

Hi

  • When trying the shell command "phpunit" I get an error (see below).
  • tried to uninstall and reinstall the port. Same result :(
  • Mac OS X 10.7.2
  • Macports 2.0.3
PHP Warning:  require_once(PHP/CodeCoverage/Filter.php): failed to open stream: No such file or directory in /opt/local/bin/phpunit on line 37
PHP Stack trace:
PHP   1. {main}() /opt/local/bin/phpunit:0

Warning: require_once(PHP/CodeCoverage/Filter.php): failed to open stream: No such file or directory in /opt/local/bin/phpunit on line 37

Call Stack:
    0.0091     629144   1. {main}() /opt/local/bin/phpunit:0

PHP Fatal error:  require_once(): Failed opening required 'PHP/CodeCoverage/Filter.php' (include_path='.::/opt/local/lib/php/pear') in /opt/local/bin/phpunit on line 37
PHP Stack trace:
PHP   1. {main}() /opt/local/bin/phpunit:0

Fatal error: require_once(): Failed opening required 'PHP/CodeCoverage/Filter.php' (include_path='.::/opt/local/lib/php/pear') in /opt/local/bin/phpunit on line 37

Call Stack:
    0.0091     629144   1. {main}() /opt/local/bin/phpunit:0

Thanks a lot for your support!

Change History (4)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to singingwolfboy@…
Summary: php5-unit @3.5.15 (php, devel), Revision 2 + installation does notphp5-unit: Failed opening required 'PHP/CodeCoverage/Filter.php'

Confirmed.

comment:2 Changed 8 years ago by jmroot (Joshua Root)

Summary: php5-unit: Failed opening required 'PHP/CodeCoverage/Filter.php'php5-unit @3.5.15: Failed opening required 'PHP/CodeCoverage/Filter.php'

Don't remove the version information please, Ryan.

comment:3 Changed 7 years ago by jmroot (Joshua Root)

Owner: changed from singingwolfboy@… to macports-tickets@…

-> nomaintainer

comment:4 Changed 4 years ago by mf2k (Frank Schima)

Resolution: wontfix
Status: newclosed

The php5-unit port no longer exists.

Note: See TracTickets for help on using tickets.