Opened 6 years ago

Closed 6 years ago

#32689 closed defect (fixed)

libpqxx does not build with clang

Reported by: cjones051073 (Chris Jones) Owned by: dweber@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: clang Cc:
Port: libpqxx

Description (last modified by ryandesign (Ryan Schmidt))

libpqxx doesn't build on OSX 10.7 with Xcode 10.7. Log attached.

It appears the problem is it doesn't like clang, which is the default compiler in this case.

Forcing the use of llvm works OK. Recommendations for working around this in the Portfile are at

wiki:PortfileRecipes#compiler

Chris

Attachments (1)

main.log.gz (3.4 KB) - added by cjones051073 (Chris Jones) 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by cjones051073 (Chris Jones)

Attachment: main.log.gz added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: clang added
Owner: changed from macports-tickets@… to dweber@…
Summary: libpqxx does not build with clang (default for OSX 10.7 + Xcode 4.2)libpqxx does not build with clang

comment:2 Changed 6 years ago by cjones051073 (Chris Jones)

Of course, I mean Xcode 4.2, not 10.7 ....

comment:3 Changed 6 years ago by cjones051073 (Chris Jones)

patch submitted for this ...

ticket #32882

Chris

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

It looks like updating to 4.0 will also fix this so we should probably do that instead.

comment:5 Changed 6 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.