Opened 9 years ago

Closed 9 years ago

#32697 closed defect (fixed)

64-bit compiled tcpick port hits segmentation fault during execution

Reported by: frazierjason@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: tcpick

Description (last modified by mf2k (Frank Schima))

The 'tcpick' port is broken for OS X 10.6 and higher where 64-bit builds are the default. There is a known issue with the source code for this project where building 64-bit on OS X causes a segmentation fault during normal use. A fix has not been entertained by the tcpick project community, and a workaround (force build for 32-bit) is confirmed to work by a few users, including myself. http://sourceforge.net/mailarchive/forum.php?forum=tcpick-project

Can someone make a minor addition to the tcpick Portfile? Just add this one line to allow OS X 10.6 clients to successfully use this port by building it in 32-bit mode. I have confirmed it to work on Snow Leopard.

supported_archs           i386 ppc

Change History (3)

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: tcpick segmentation fault removed
Type: requestdefect

comment:2 Changed 9 years ago by drkp (Dan Ports)

Owner: changed from macports-tickets@… to dports@…
Status: newassigned

Looks like it also fails to build with clang...

comment:3 Changed 9 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.