Opened 9 years ago

Closed 9 years ago

#32826 closed update (duplicate)

appengine-java-sdk 1.3.8 upgrade to 1.6.1

Reported by: nhojpatrick (John Patrick) Owned by: dmunneke@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: appengine-java-sdk

Description

Just noticed appengine-java-sdk has an avaliable upgrade to 1.6.1. Patch attached.

Attachments (3)

Portfile-upgrade-to-1.6.1.2.diff (835 bytes) - added by nhojpatrick (John Patrick) 9 years ago.
Portfile-upgrade-to-1.6.1.diff (835 bytes) - added by nhojpatrick (John Patrick) 9 years ago.
appengine-java-sdk_89267_Portfile_upgrade-to-1.6.1.1.diff (837 bytes) - added by nhojpatrick (John Patrick) 9 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Cc: openmaintainer@… removed
Keywords: haspatch added
Owner: changed from macports-tickets@… to dmunneke@…
Version: 2.0.3

Note that "openmaintainer@…" is not a valid email address, the other one for dmunneke is however and I have updated the ticket.

Adding the rmd160 checksum is good. But please do not add an md5 checksum as it is obsolete and not secure. Changing the sha1 checksum to sha256 would be nice.

comment:2 Changed 9 years ago by nhojpatrick (John Patrick)

You might want to update the documentation, as I used that when trying to work out what email address to cc as well also the checksum types to use.

comment:3 Changed 9 years ago by mf2k (Frank Schima)

The "Assign To" section mentions "Exclude the email address <openmaintainer@…> if it appears". But I agree that the Cc part should mention that too. The checksum section definitely needs to be updated.

Changed 9 years ago by nhojpatrick (John Patrick)

Changed 9 years ago by nhojpatrick (John Patrick)

comment:4 Changed 9 years ago by nhojpatrick (John Patrick)

Patch update to only have sha256 and rmd160 checksums, and not use md5 or sha1.

comment:5 Changed 9 years ago by nhojpatrick (John Patrick)

appengine-java-sdk version 1.6.1.1 is now available, patch updated for this version.

Changed 9 years ago by nhojpatrick (John Patrick)

comment:6 Changed 9 years ago by nhojpatrick (John Patrick)

Any update on accepting this patch to update the version? Just wondering as 1.6.3 is nearly out, no update for 5 weeks...

comment:7 Changed 9 years ago by nhojpatrick (John Patrick)

dmunneke, any news, any progress, anything wrong, any issue with patch???

Anything that I can do?

comment:8 Changed 9 years ago by nhojpatrick (John Patrick)

If https://trac.macports.org/ticket/34254 accepted, this can be closed as appengine-java-sdk is now at 1.6.5.

comment:9 Changed 9 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Superseded as per comment:8.

Note: See TracTickets for help on using tickets.