Opened 9 years ago

Closed 9 years ago

#32847 closed defect (duplicate)

Error with makefiles while installing graphviz

Reported by: niksoft@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: graphviz

Description (last modified by ryandesign (Ryan Schmidt))

--->  Building graphviz
DEBUG: Executing org.macports.build (graphviz)
DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.7'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz/work/graphviz-2.28.0" && /usr/bin/make -j2 -w all'
DEBUG: Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz/work/graphviz-2.28.0" && /usr/bin/make -j2 -w all 
make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz/work/graphviz-2.28.0'
 cd . && /bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz/work/graphviz-2.28.0/config/missing --run automake-1.11 --gnu
plugin/ming/Makefile.am:20: `pkglibdir' is not a legitimate directory for `DATA'
tclpkg/gv/Makefile.am:136: shell $(PERL: non-POSIX variable name
tclpkg/gv/Makefile.am:136: (probably a GNU make extension)
tclpkg/gv/Makefile.am:137: shell $(PERL: non-POSIX variable name
tclpkg/gv/Makefile.am:137: (probably a GNU make extension)
tclpkg/gv/Makefile.am:138: shell $(PERL: non-POSIX variable name
tclpkg/gv/Makefile.am:138: (probably a GNU make extension)
tclpkg/gv/Makefile.am:260: `pkgincludedir' is not a legitimate directory for `DATA'
make: *** [Makefile.in] Error 1
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz/work/graphviz-2.28.0'
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_graphviz/graphviz/work/graphviz-2.28.0" && /usr/bin/make -j2 -w all " returned error 2
Error: Target org.macports.build returned: shell command failed (see log for details)
DEBUG: Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for graphviz): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

Change History (2)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Description: modified (diff)
Keywords: graphviz removed
Owner: changed from macports-tickets@… to ryandesign@…

Duplicate of #32688, already fixed. "sudo port selfupdate" and "sudo port clean graphviz" and try again.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.