Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#32867 closed defect (invalid)

Where is config file in Xournal

Reported by: eps222@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: Xournal

Description

The Macports version of Xournal is great. But I can't seem to find the config file. In standard Xournal (meaning, when it's installed on Linux), the file is supposed to be at ~user/.xournal/config.

See http://xournal.sourceforge.net/manual.html#configuration. But in MacPorts, there's no such directory. The config file must be in there SOMEWHERE, or else the program wouldn't work. I'm sorry to post such a piddling question, but I've searched the boards and can't find any help. Thanks so much!

Change History (4)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Keywords: Xournal config removed
Resolution: invalid
Status: newclosed

As far as I can tell, it behaves exactly as the documentation describes: "Xournal's configuration settings are saved to the file ~user/.xournal/config by using the "Save Preferences" command in the Options menu." For further questions about how xournal works, you should ask the developers of xournal, unless you believe there is a MacPorts-specific difference.

comment:2 in reply to:  1 Changed 9 years ago by eps222@…

Resolution: invalid
Status: closedreopened

Thank you for your comment. But, if you can please indulge me for a minute, I'm still confused. The issue is not with Xournal. It's simply that, within the MacPorts environment, I'm having trouble finding a folder that Xournal creates. As you wrote back to me, and as the Xournal instructions state, the config file is located in ~user/.xournal/config. But, within the MacPorts environment, no folder is named "user." To be clear, MacPorts installs everything in the ~opt folder. Within that folder, there are two main folders: local and X11. Within local, there are several subfolders - none are called "user". One of the subfolders - the one with the Xournal binary - is called bin. There is no subfolder within bin, or anywhere else I can find, called user. And there are also no subfolders called "user" under within the X11 folder. I'm sure that MacPorts creates the ~user/.xournal/config. somewhere. The help that I'm asking you for is to please point me to where MacPorts places this folder. Thank you again for all of your help, both with this and for your great working porting such a helpful program.

Replying to ryandesign@…:

As far as I can tell, it behaves exactly as the documentation describes: "Xournal's configuration settings are saved to the file ~user/.xournal/config by using the "Save Preferences" command in the Options menu." For further questions about how xournal works, you should ask the developers of xournal, unless you believe there is a MacPorts-specific difference.

comment:3 Changed 9 years ago by neverpanic (Clemens Lang)

Resolution: invalid
Status: reopenedclosed

~user is unix-shorthand for the home directory of the user "user", so if your username was "abcde", cd ~abcde would bring you into your home directory. And that's where xournal places it's config file.

MacPorts does not attempt to write into a user's home directory and should not, so this is not a bug. The file is not created by MacPorts, but by Xournal as it deems necessary.

comment:4 in reply to:  3 Changed 9 years ago by eps222@…

Thanks - I'm all set now! Sorry for not understanding that.

Replying to cal@…:

~user is unix-shorthand for the home directory of the user "user", so if your username was "abcde", cd ~abcde would bring you into your home directory. And that's where xournal places it's config file.

MacPorts does not attempt to write into a user's home directory and should not, so this is not a bug. The file is not created by MacPorts, but by Xournal as it deems necessary.

Note: See TracTickets for help on using tickets.