Opened 9 years ago

Closed 9 years ago

#33041 closed defect (invalid)

expat: configure: error: C compiler cannot create executables

Reported by: srabanti@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: expat

Description

I have installed Macports before but today when I am trying to put it on Macbook air it crashed. I couldn't install wine to run some windows program. This mac book air is i7 processor and runs on Lion. I have installed Xcode 4 and X11 was already there. I installed the Macports 2.0.3 and then when I tried to run sudo install wine it failed

Attachments (2)

Aerror.rtf (1.7 KB) - added by srabanti@… 9 years ago.
error that shows when installing wine
log.rtf (2.4 KB) - added by srabanti@… 9 years ago.
log file.

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by srabanti@…

Attachment: Aerror.rtf added

error that shows when installing wine

Changed 9 years ago by srabanti@…

Attachment: log.rtf added

log file.

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: wine macports shell expact removed
Port: expat added
Priority: HighNormal
Resolution: invalid
Status: newclosed
Summary: Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)expat: configure: error: C compiler cannot create executables

The log says:

:info:configure checking for C compiler default output file name... configure: error: C compiler cannot create executables

If you are running a released version of Xcode such as 4.0, 4.1, 4.2, or 4.2.1, then per our FAQ this means Xcode is not installed properly; reinstall Xcode per our guidelines.

If you are running a pre-release version of Xcode such as 4.3.x then you should install the development version of MacPorts from trunk; MacPorts 2.0.3 is not compatible with Xcode 4.3.x.

comment:2 Changed 9 years ago by srabanti@…

Resolution: invalid
Status: closedreopened

Hi
I checked the xcode installation and it works fine. Through App store it is installed and version is 4.2.1 and it automatically takes care of the installation. Unlike previous version the installation is done without any options given. I have installed Macports and wine before and it works fine with Xcode 4.1. However when I tried this on Xcode 4.2.1 the wine installation fails.

Here is the error log:

version:1
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 502
:debug:main Executing org.macports.main (expat)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.archivefetch (expat)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (expat)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.checksum (expat)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.extract (expat)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.patch (expat)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:configure configure phase started at Fri Feb  3 10:08:04 EST 2012
:notice:configure --->  Configuring expat
:debug:configure Using compiler 'Mac OS X clang'
:debug:configure Executing org.macports.configure (expat)
:debug:configure Environment: CPATH='/opt/local/include' CFLAGS='-pipe -O2 -arch i386 -arch ppc' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-pipe -O2 -arch i386 -arch ppc' LIBRARY_PATH='/opt/local/lib' MACOSX_DEPLOYMENT_TARGET='10.7' CXX='/D

i386 -arch ppc' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-pipe -O2 -arch i386 -arch ppc' LIBRARY_PATH='/opt/local/lib' MACOSX_DEPLOYMENT_TARGET='10.7' CXX='/Developer/usr/bin/clang++' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_expat/expat/work/.CC_PRINT_OPTIONS' F90FLAGS='-pipe -O2' LDFLAGS='-L/opt/local/lib -arch i386 -arch ppc' OBJC='/Developer/usr/bin/clang' FCFLAGS='-pipe -O2' INSTALL='/usr/bin/install -c' OBJCFLAGS='-pipe -O2 -arch i386 -arch ppc' FFLAGS='-pipe -O2' CC_PRINT_OPTIONS='YES' CC='/Developer/usr/bin/clang'
:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_expat/expat/work/expat-2.0.1" && ./configure --prefix=/opt/local --disable-dependency-tracking --mandir=/opt/local/share/man'
:debug:configure Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_expat/expat/work/expat-2.0.1" && ./configure --prefix=/opt/local --disable-dependency-tracking --mandir=/opt/local/share/man 
:info:configure checking build system type... i386-apple-darwin11.2.0
:info:configure checking host system type... i386-apple-darwin11.2.0
:info:configure checking for gcc... /Developer/usr/bin/clang
:info:configure checking for C compiler default output file name... configure: error: C compiler cannot create executables
:info:configure See `config.log' for more details.
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_expat/expat/work/expat-2.0.1" && ./configure --prefix=/opt/local --disable-dependency-track:
info:configure checking build system type... i386-apple-darwin11.2.0
:info:configure checking host system type... i386-apple-darwin11.2.0
:info:configure checking for gcc... /Developer/usr/bin/clang
:info:configure checking for C compiler default output file name... configure: error: C compiler cannot create executables
:info:configure See `config.log' for more details.
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_expat/expat/work/expat-2.0.1" && ./configure --prefix=/opt/local --disable-dependency-tracking --mandir=/opt/local/share/man " returned error 77
:error:configure Target org.macports.configure returned: configure failure: shell command failed (see log for details)
:debug:configure Backtrace: configure failure: shell command failed (see log for details)
    while executing
"$procedure $targetname"
:info:configure Warning: the following items did not execute (for expat): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:error:configure Failed to install expat
:debug:configure couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing
"open [file join $dir tclIndex]"
:notice:configure Log for expat is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_expat/expat/main.log

comment:3 Changed 9 years ago by neverpanic (Clemens Lang)

Please attach config.log from $(port work expat)/expat-2.0.1/.

comment:4 Changed 9 years ago by mf2k (Frank Schima)

How did you check that Xcode 4.2.1 was installed correctly? So what is the output of the following?

clang -v

comment:5 Changed 9 years ago by srabanti@…

I will get teh config file as soon as I can. I started xcode and ran a small test.c file to check it.I didn't check clang -v Thansk.

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

Please remember to use WikiFormatting.

-arch i386 -arch ppc

Why are you trying to build for i386 and ppc on Lion? Lion is an x86_64 OS. It sounds like you may have an ancient macports.conf. Spend some time updating your macports.conf with the new recommended values in your macports.conf.default.

comment:7 Changed 9 years ago by srabanti@…

I have used the same macport conf file for other Lion machine and I never need to change. I did macports source installation as .dmg file installation was not working.

comment:8 Changed 9 years ago by ryandesign (Ryan Schmidt)

The only reason why MacPorts would try to use the architectures i386 and ppc for building expat is if you requested the universal variant (which is what would happen when you try to install wine on Snow Leopard or later), and if the universal_archs setting in macports.conf is set to i386 ppc. This value would be appropriate for Leopard and earlier, but not for Snow Leopard or later. Please change universal_archs in macports.conf to i386 x86_64. You may have other outdated settings in macports.conf so you should check them all against the new defaults in macports.conf.default.

comment:9 in reply to:  3 Changed 9 years ago by srabanti@…

Replying to cal@…:

Please attach config.log from $(port work expat)/expat-2.0.1/.

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by expat configure 2.0.1, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ./configure --prefix=/opt/local --disable-dependency-tracking --mandir=/opt/local/share/man

## --------- ##
## Platform. ##
## --------- ##

hostname = pc176-157.odef.uwindsor.ca
uname -m = x86_64
uname -r = 11.2.0
uname -s = Darwin
uname -v = Darwin Kernel Version 11.2.0: Tue Aug  9 20:54:00 PDT 2011; root:xnu-1699.24.8~1/RELEASE_X86_64

/usr/bin/uname -p = i386
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = Mach kernel version:
         Darwin Kernel Version 11.2.0: Tue Aug  9 20:54:00 PDT 2011; root:xnu-1699.24.8~1/RELEASE_X86_64
Kernel configured for up to 4 processors.
2 processors are physically available.
4 processors are logically available.
Processor type: i486 (Intel 80486)
Processors active: 0 1 2 3
Primary memory available: 4.00 gigabytes
Default processor set: 92 tasks, 523 threads, 4 processors
Load average: 1.49, Mach factor: 2.50
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /opt/local/bin
PATH: /opt/local/sbin
PATH: /bin
PATH: /sbin
PATH: /usr/bin
PATH: /usr/sbin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2092: checking build system type
configure:2110: result: i386-apple-darwin11.2.0
configure:2118: checking host system type
configure:2132: result: i386-apple-darwin11.2.0
configure:2186: checking for gcc
configure:2212: result: /Developer/usr/bin/clang
configure:2456: checking for C compiler version
configure:2459: /Developer/usr/bin/clang --version </dev/null >&5
Apple clang version 3.0 (tags/Apple/clang-211.12) (based on LLVM 3.0svn)
Target: x86_64-apple-darwin11.2.0
Thread model: posix
configure:2462: $? = 0
configure:2464: /Developer/usr/bin/clang -v </dev/null >&5
Apple clang version 3.0 (tags/Apple/clang-211.12) (based on LLVM 3.0svn)
Target: x86_64-apple-darwin11.2.0
Thread model: posix
configure:2467: $? = 0
configure:2469: /Developer/usr/bin/clang -V </dev/null >&5
clang: error: argument to '-V' is missing (expected 1 value)
clang: error: no input files
configure:2472: $? = 1
configure:2495: checking for C compiler default output file name
configure:2498: /Developer/usr/bin/clang -pipe -O2 -arch i386 -arch ppc -I/opt/local/include -L/opt/local/lib -arch i386 -arch ppc conftest.c  >&5
clang: warning: not using the clang compiler for the 'powerpc' architecture
llvm-gcc-4.2: error trying to exec '/Developer/usr/bin/../llvm-gcc-4.2/bin/powerpc-apple-darwin11-llvm-gcc-4.2': execvp: No such file or directory
clang: error: gcc frontend command failed with exit code 255 (use -v to see invocation)
configure:2501: $? = 255
configure: failed program was:
| /* confdefs.h.  */
| 
| #define PACKAGE_NAME "expat"
| #define PACKAGE_TARNAME "expat"
| #define PACKAGE_VERSION "2.0.1"
| #define PACKAGE_STRING "expat 2.0.1"
| #define PACKAGE_BUGREPORT "expat-bugs@libexpat.org"
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }
configure:2540: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i386-apple-darwin11.2.0
ac_cv_build_alias=i386-apple-darwin11.2.0
ac_cv_env_CC_set=set
ac_cv_env_CC_value=/Developer/usr/bin/clang
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-pipe -O2 -arch i386 -arch ppc'
ac_cv_env_CPPFLAGS_set=set
ac_cv_env_CPPFLAGS_value=-I/opt/local/include
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=set
ac_cv_env_CXXFLAGS_value='-pipe -O2 -arch i386 -arch ppc'
ac_cv_env_CXX_set=set
ac_cv_env_CXX_value=/Developer/usr/bin/clang++
ac_cv_env_F77_set=
ac_cv_env_F77_value=
ac_cv_env_FFLAGS_set=set
ac_cv_env_FFLAGS_value='-pipe -O2'
ac_cv_env_LDFLAGS_set=set
ac_cv_env_LDFLAGS_value='-L/opt/local/lib -arch i386 -arch ppc'
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i386-apple-darwin11.2.0
ac_cv_host_alias=i386-apple-darwin11.2.0
ac_cv_prog_ac_ct_CC=/Developer/usr/bin/clang

## ----------------- ##
## Output variables. ##
## ----------------- ##

AR=''
AS=''
CC='/Developer/usr/bin/clang'
CFLAGS='-pipe -O2 -arch i386 -arch ppc'
CPP=''
CPPFLAGS='-I/opt/local/include'
CXX='/Developer/usr/bin/clang++'
CXXCPP=''
CXXFLAGS='-pipe -O2 -arch i386 -arch ppc'
DEFS=''
DLLTOOL=''
ECHO='/bin/echo'
ECHO_C='ECHO_N=''
ECHO_T=''
EGREP=''
EXEEXT=''
F77=''
FFLAGS='-pipe -O2'
FILEMAP=''
INSTALL_DATA=''
INSTALL_PROGRAM=''
INSTALL_SCRIPT=''
LDFLAGS='-L/opt/local/lib -arch i386 -arch ppc'
LIBAGE='5'
LIBCURRENT='6'
LIBOBJS=''
LIBREVISION='2'
LIBS=''
LIBTOOL=''
LN_S=''
LTLIBOBJS=''
OBJDUMP=''
OBJEXT=''
PACKAGE_BUGREPORT='expat-bugs@libexpat.org'
PACKAGE_NAME='expat'
PACKAGE_STRING='expat 2.0.1'
PACKAGE_TARNAME='expat'
PACKAGE_VERSION='2.0.1'
PATH_SEPARATOR=':'
RANLIB=''
SHELL='/bin/sh'
STRIP=''
ac_ct_AR=''
ac_ct_AS=''
ac_ct_CC='/Developer/usr/bin/clang'
ac_ct_CXX=''
ac_ct_DLLTOOL=''
ac_ct_F77=''
ac_ct_OBJDUMP=''
ac_ct_RANLIB=''
ac_ct_STRIP=''
bindir='${exec_prefix}/bin'
build='i386-apple-darwin11.2.0'
build_alias=''
build_cpu='i386'
build_os='darwin11.2.0'
build_vendor='apple'
datadir='${prefix}/share'
exec_prefix='NONE'
host='i386-apple-darwin11.2.0'
host_alias=''
host_cpu='i386'
host_os='darwin11.2.0'
host_vendor='apple'
includedir='${prefix}/include'
infodir='${prefix}/info'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='${prefix}/var'
mandir='/opt/local/share/man'
oldincludedir='/usr/include'
prefix='/opt/local'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_BUGREPORT "expat-bugs@libexpat.org"
#define PACKAGE_NAME "expat"
#define PACKAGE_STRING "expat 2.0.1"
#define PACKAGE_TARNAME "expat"
#define PACKAGE_VERSION "2.0.1"

configure: exit 77

comment:10 Changed 9 years ago by ryandesign (Ryan Schmidt)

I wish you had attached the file, rather than pasting it without WikiFormatting, but nevertheless it confirms that the problem is that you're trying to build for PowerPC on Lion. Don't try to build for PowerPC on Lion. Modify your macports.conf as I indicated above.

comment:11 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.