Opened 9 years ago

Closed 6 years ago

#33051 closed update (fixed)

gnokii 0.6.31 port update

Reported by: sjoerd@… Owned by: mpal1+bugzilla@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: kurthindenburg (Kurt Hindenburg)
Port: gnokii

Description

Changed checksums accordingly.

I had to outcomment

patchfiles fink-fixes.diff

don't know why, but here it compiles correctly. Maybe these fixes were already incorporated in the source?

Attachments (1)

Portfile-gnokii.diff (1.2 KB) - added by sjoerd@… 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by sjoerd@…

Attachment: Portfile-gnokii.diff added

comment:1 Changed 9 years ago by raimue (Rainer Müller)

The build failed for me on Mac OS X 10.7 Lion:

Undefined symbols for architecture x86_64:
  "_IOBluetoothDeviceOpenRFCOMMChannel", referenced from:
      _thread_main in libDEVICES.a(libDEVICES_la-osxbluetooth.o)
  "_IOBluetoothRFCOMMChannelRegisterIncomingDataListener", referenced from:
      _thread_main in libDEVICES.a(libDEVICES_la-osxbluetooth.o)
      _bluetooth_close in libDEVICES.a(libDEVICES_la-osxbluetooth.o)
  "_IOBluetoothRFCOMMChannelWrite", referenced from:
      _bluetooth_write in libDEVICES.a(libDEVICES_la-osxbluetooth.o)
ld: symbol(s) not found for architecture x86_64

This is most probably *not* be a regression, as it looks like the corresponding bluetooth API was removed from Mac OS X 10.7 as stated in the API Release Notes. Although I did not try to build the old gnokii @0.6.27.

comment:2 Changed 8 years ago by jmroot (Joshua Root)

Cc: mpal1+bugzilla@… removed
Keywords: haspatch added
Owner: changed from macports-tickets@… to mpal1+bugzilla@…
Version: 2.0.3

comment:3 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added

Cc Me!

comment:4 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

Resolution: fixed
Status: newclosed

this was updated a while ago

r96255 | raimue@macports.org | 2012-08-06 12:27:41 -0400 (Mon, 06 Aug 2012) | 4 lines

comms/gnokii:
Update to version 0.6.31, disable bluetooth as that does not work on recent
versions of Mac OS X. Maintainer timeout on #34162.
Note: See TracTickets for help on using tickets.