New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #33129 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

git-core: build removes /dev/null from the system

Reported by: dev@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: git-core

Description

It look like the build system deletes /dev/null file from the system on OSX Lion 10.7.3. System is crippled after running sudo port install git-core for example (which fails anyway because of that I think).

I try to install git-core on my system after upgrading to 10.7.3. It fails with the following message:

danielk-macbook:~ danielk$ sudo port install git-core
Password:
--->  Computing dependencies for git-core
--->  Staging git-core into destroot
Error: Target org.macports.destroot returned: shell command failed (see log for details)
Log for git-core is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_git-core/git-core/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

after that /dev/null is gone missing and OS starts to behave weird. Rebooting helps but it also behave weird: machine boot reboot itself and only then the os startups ok. What's going on?

Attachments

log.zip (6.7 KB) - added by dev@… 2 years ago.

Change History

Changed 2 years ago by dev@…

comment:1 Changed 2 years ago by cal@…

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #33127.

comment:2 Changed 2 years ago by cal@…

  • Priority changed from High to Normal
  • Port set to git-core

comment:3 Changed 2 years ago by ryandesign@…

  • Summary changed from macports build removes /dev/null from the system??? to git-core: build removes /dev/null from the system
Note: See TracTickets for help on using tickets.