Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#33164 closed defect (fixed)

texlive-xetex: xetex is stymied

Reported by: raphael-st (Raphael Straub) Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: harish.mlists@…
Port: texlive-xetex

Description

When running xelatex I get

This is XeTeX, Version 3.1415926-2.3-0.9997.5 (TeX Live 2011/MacPorts 2011_4)
 restricted \write18 enabled.
(Fatal format file error; I'm stymied)

Even running fmtutil-sys --all, which completes without any obvious errors, does not help. I found a bug report that says that this might be an incompatibility with zlib 1.2.6.

Change History (9)

comment:1 Changed 8 years ago by drkp (Dan Ports)

Status: newassigned

comment:2 Changed 8 years ago by drkp (Dan Ports)

Hmm, it works for me. Let me see if I can reproduce on a different system...

comment:3 Changed 8 years ago by raphael-st (Raphael Straub)

I saw this behavior on Leopard (powerpc and i386) and Snow Leopard (i386 and x86_64).

comment:4 Changed 8 years ago by harish.mlists@…

I see the same problem too on Lion (x86_64).

comment:5 Changed 8 years ago by harish.mlists@…

Cc: harish.mlists@… added

Cc Me!

comment:6 Changed 8 years ago by drkp (Dan Ports)

Yes, I see it now too. I'm testing a possible fix.

comment:7 Changed 8 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed

xetex should no longer be stymied as of r89696.

comment:8 in reply to:  7 Changed 8 years ago by Sylvain.Soliman+macports@…

Replying to dports@…:

xetex should no longer be stymied as of r89696.

I can confirm that the fix indeed solves the stymification issue here (Snow Leopard x86_64). Thanks for the quick response.

comment:9 Changed 8 years ago by harish.mlists@…

The fix works for me too (Lion x86_64). Thank you.

Note: See TracTickets for help on using tickets.