Opened 9 years ago

Closed 9 years ago

#33178 closed defect (duplicate)

xymon-server 4.3.7 doesn't ensure it's UsingTheRightCompiler

Reported by: ryandesign (Ryan Schmidt) Owned by: fclaire@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: xymon-server

Description

xymon-server doesn't ensure it's UsingTheRightCompiler:

Configuration script for Xymon

This script asks a few questions and builds a Makefile to compile Xymon

Checking your make-utility
Checking pre-requisites for building Xymon

Checking for fping ...
OK, will use '/opt/local/sbin/fping' for ping tests


Checking for RRDtool ...
gcc -g -O -Wall -Wno-unused -D_REENTRANT -DBIND_8_COMPAT=1 -DDarwin -I/opt/local/include -o test-rrd.o -c test-rrd.c
gcc: Error: You should be using ${configure.cc}
See https://trac.macports.org/wiki/UsingTheRightCompiler
make: *** [test-compile] Error 1
Not RRDtool 1.0.x, checking for 1.2.x
gcc -g -O -Wall -Wno-unused -D_REENTRANT -DBIND_8_COMPAT=1 -DDarwin -DRRDTOOL12 -I/opt/local/include -o test-rrd.o -c test-rrd.c
gcc: Error: You should be using ${configure.cc}
See https://trac.macports.org/wiki/UsingTheRightCompiler
make: *** [test-compile] Error 1

Change History (1)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Sorry, duplicate of #30616.

Note: See TracTickets for help on using tickets.