Opened 9 years ago

Closed 9 years ago

#33185 closed defect (duplicate)

transfig: error: empty character constant

Reported by: lesn0011@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: transfig

Description (last modified by ryandesign (Ryan Schmidt))

Using OS Lion with iMac i7 Quad Core

Here is the terminal screen:

$ sudo port install arb
Password
:--->  Computing dependencies for arb
--->  Dependencies to be installed: xfig transfig xorg-libXaw groff psutils texinfo
--->  Configuring transfig
Error: Target org.macports.configure returned: xmkmf failure: shell command failed (see log for details)
Error: Failed to install transfig
Log for transfig is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_transfig/transfig/main.log
Error: The following dependencies were not installed: xfig transfig xorg-libXaw groff psutils texinfo
Error: Status 1 encountered during processing.

Here is the log for transfig:

more /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_transfig/transfig/main.log
version:1
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 507
:debug:main Executing org.macports.main (transfig)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.archivefetch (transfig)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (transfig)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.checksum (transfig)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.extract (transfig)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.patch (transfig)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:configure configure phase started at Tue Feb  7 17:02:02 PST 2012
:notice:configure --->  Configuring transfig
:debug:configure Using compiler 'Mac OS X clang'
:debug:configure Executing org.macports.configure (transfig)
:debug:configure Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_transfig/transfig/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.7'
:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_transfig/transfig/work/transfig.3.2.5d" && xmkmf'
:debug:configure Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_transfig/transfig/work/transfig.3.2.5d" && xmkmf 
:info:configure mv -f Makefile Makefile.bak
:info:configure imake -DUseInstalled -I/opt/local/lib/X11/config
:info:configure In file included from Imakefile.c:15:
:info:configure In file included from /opt/local/lib/X11/config/Imake.tmpl:316:
:info:configure /opt/local/lib/X11/config/Imake.rules:1674:27: error: empty character constant
:info:configure         for flag in ${MAKEFLAGS} ''; do \                               @@\
:info:configure                                  ^
:info:configure In file included from Imakefile.c:15:
:info:configure /opt/local/lib/X11/config/Imake.tmpl:2144:10: fatal error: ' X11 .rules' file not found
:info:configure #include ProjectRulesFile
:info:configure          ^
:info:configure /opt/local/lib/X11/config/Imake.tmpl:2142:27: note: instantiated from:
:info:configure # define ProjectRulesFile       Concat3(<,TopLevelProject,.rules>)

Change History (1)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Keywords: arb transfig removed
Milestone: MacPorts 2.0.4
Port: transfig added
Resolution: duplicate
Status: newclosed
Summary: arb failed installtransfig: error: empty character constant

Duplicate of #33165.

Note: See TracTickets for help on using tickets.