Opened 9 years ago

Closed 9 years ago

#33186 closed defect (worksforme)

texlive-bin Build failure, missing Xaw headers

Reported by: illix16@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: texlive-bin

Description

The texlive-bin package is failing to install on my machine with this error:

:info:build checking for XawInitializeWidgetSet in -lXaw... no
:info:build configure: error: Sorry, you will need at least the Xaw header/library files to compile xdvik.
:info:build === configuring in xdvik failed
:info:build make[2]: *** [subtexk] Error 1

However, I have already installed the xorg-libXaw package, and checked to make sure the files are there in /opt/local/X11. I've also tried running with a different compiler using

port install texlive configure.compiler=llvm-gcc-4.2

and I get the same error. Any idea what's going on?

Note: this is after an upgrade to Lion. texlive functioned just fine under 10.6.

Attachments (1)

config.log (136.7 KB) - added by illix16@… 9 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by drkp (Dan Ports)

Owner: changed from macports-tickets@… to dports@…
Port: texlive-bin added

I haven't seen this before. Did you follow the Migration procedures when upgrading from 10.6?

Can you upload the config.log file from $(port work texlive-bin)/texlive-20110705-source-stripped/texk/xdvik/config.log ?

Changed 9 years ago by illix16@…

Attachment: config.log added

comment:2 Changed 9 years ago by illix16@…

I thought I followed the Migration procedures correctly (installing texlive-bin is part of reinstalling my previous ports). I should note that I have had a slew of other problems reinstalling texlive after wiping the ports, most of which I sadly did not think to document at the time; it completely failed to find the X11 libraries, and my attempts to fix this culminated in needing to reinstall X11 completely from the XQuartz distribution (as Apple so thoughtfully ceased handing out install CDs with their computers, from which I could have restored the usual X11).

I've attached the requested log.

comment:3 Changed 9 years ago by drkp (Dan Ports)

Sorry, I didn't notice the log until now.

Can you confirm that you have /opt/local/lib/libXpm.dylib installed? What does port -v installed xpm say?

comment:4 Changed 9 years ago by drkp (Dan Ports)

Resolution: worksforme
Status: newclosed

Closing due to lack of response.

Note: See TracTickets for help on using tickets.