Opened 9 years ago

Closed 9 years ago

#33200 closed defect (invalid)

texlive-bin @2011, Revision 5, on upgrade: invalid libtool wrapper script `tangle'

Reported by: j_simon@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: texlive-bin

Description

Hi to all Mac Port Devs out there. I have the following problem, where I couldn't google any solution yet:

When I do a sudo port selfupdate, and then a sudo port upgrade outdated I get the following error:

--->  Computing dependencies for texlive-bin--->  Staging texlive-bin into destroot
Error: Target org.macports.destroot returned: shell command failed (see log for details)
Log for texlive-bin is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_tex_texlive-bin/texlive-bin/main.log
Error: Unable to upgrade port: 1

The log file suggests it has something to do with libtool, especially in line 478 ":info:destroot libtool: install: invalid libtool wrapper script `tangle'" but I have no clear idea what to do....

the log file should be attached....

Attachments (1)

main.log (78.6 KB) - added by j_simon@… 9 years ago.
log file of texlive-bin from the update

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by j_simon@…

Attachment: main.log added

log file of texlive-bin from the update

comment:1 Changed 9 years ago by j_simon@…

Cc: j_simon@… added

Cc Me!

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: j_simon@… removed
Milestone: MacPorts 2.0.4
Owner: changed from macports-tickets@… to dports@…
Port: libtool removed

This is not a clean attempt. Please "sudo port clean texlive-bin" and try again, and attach the new complete main.log if it fails again.

comment:3 Changed 9 years ago by drkp (Dan Ports)

In addition to that log, it'd be interesting to see the contents of $(port work texlive-bin)/texlive-20110705-source-stripped/texk/web2c/ctangle, so please attach that too.

comment:4 Changed 9 years ago by j_simon@…

Sorry, I have been ill for quite a while now Actually the "sudo port clean texlive-bin" really solved the problem. I was almost sure I did that, but I guess it was just almost @_@

Thanks for the help anyway! Cheers, Jörg

comment:5 Changed 9 years ago by drkp (Dan Ports)

Resolution: invalid
Status: newclosed

No problem. Glad it worked; hope you feel better.

Note: See TracTickets for help on using tickets.