Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#33202 closed defect (wontfix)

HexFiend doesn't work on systems < 10.6

Reported by: nonstop.server@… Owned by: dweber@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: leopard Cc: neverpanic (Clemens Lang)
Port: hexfiend

Description

Port hexfiend fails to update from version 2.0_0 to version 2.1.2.

:info:build ** BUILD FAILED **
:info:build 
:info:build The following build commands failed:
:info:build FortunateSon (PrivilegedHelper):
:info:build     CompileC "build/HexFiend_2.build/Release/FortunateSon (Privilege
dHelper).build/Objects-normal/i386/FortunateSonServerImpl.o" /opt/local/var/macp
orts/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_editors_hexfiend/HexFiend/work/HexFiend-2.1.2/helper_subprocess/FortunateSonServerImpl.cpp normal i386 c++ com.apple.compilers.gcc.4_0
:info:build HexFiend_Framework:
:info:build     ProcessPCH /var/folders/iW/iW+B+0WOEue7aWAlghiu2E+++TQ/-Caches-/com.apple.Xcode.503/SharedPrecompiledHeaders/HexFiend_2_Framework_Prefix-fhroulfjejgtevhiqbjrlzmcsajn/HexFiend_2_Framework_Prefix.pch.gch framework/sources/HexFiend_2_Framework_Prefix.pch normal i386 c com.apple.compilers.gcc.4_0
:info:build     ProcessPCH /var/folders/iW/iW+B+0WOEue7aWAlghiu2E+++TQ/-Caches-/com.apple.Xcode.503/SharedPrecompiledHeaders/HexFiend_2_Framework_Prefix-fqmqyxzicgqweydxlaatzxxawjkk/HexFiend_2_Framework_Prefix.pch.gch framework/sources/HexFiend_2_Framework_Prefix.pch normal i386 objective-c com.apple.compilers.gcc.4_0
:info:build HexFiend_2:
:info:build     ProcessPCH /var/folders/iW/iW+B+0WOEue7aWAlghiu2E+++TQ/-Caches-/com.apple.Xcode.503/SharedPrecompiledHeaders/HexFiend_2_Prefix-hauiizupqgkemabvbbpnxdnwaubd/HexFiend_2_Prefix.pch.gch app/sources/HexFiend_2_Prefix.pch normal i386 objective-c com.apple.compilers.gcc.4_0
:info:build     PBXCp "build/Release/Hex Fiend.app/Contents/Library/LaunchServices/com.ridiculousfish.HexFiend.PrivilegedHelper" build/Release/com.ridiculousfish.HexFiend.PrivilegedHelper
:info:build (6 failures)
:info:build
:info:build shell command "cd "/opt/local/var/macports/build/_opt_local_var_macp
orts_sources_rsync.macports.org_release_tarballs_ports_editors_hexfiend/HexFiend/work/HexFiend-2.1.2" && /usr/bin/xcodebuild  -target "HexFiend_2" -configuratio
n Release build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.5 ARCH
S=i386 SDKROOT="" GCC_VERSION=4.0 " returned error 1

Version Information:

Mac OS Version:
Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386

Xcode Version:
Xcode 3.1.4
Component versions: DevToolsCore-1204.0; DevToolsSupport-1186.0
BuildVersion: 9M2809

Macports Version:
Version: 2.0.3

Attachments (6)

main.log (142.5 KB) - added by nonstop.server@… 9 years ago.
darwin9.patch (1.2 KB) - added by neverpanic (Clemens Lang) 9 years ago.
Can you try with the attached patch against the Portfile and the files directory?
main_patched.log (142.9 KB) - added by nonstop.server@… 9 years ago.
main.log after applying the patch
macports_hexfiend_patched_upgrade.log (134.4 KB) - added by nonstop.server@… 9 years ago.
terminal output after applying the patch
darwin9.2.patch (1.5 KB) - added by neverpanic (Clemens Lang) 9 years ago.
revised patch for darwin9
main_2nd_patch.log (401.3 KB) - added by nonstop.server@… 9 years ago.
main.log after applying the second patch

Download all attachments as: .zip

Change History (16)

Changed 9 years ago by nonstop.server@…

Attachment: main.log added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: cal@… added; dweber@… removed
Keywords: leopard added
Owner: changed from macports-tickets@… to dweber@…
Summary: HexFiend @2.1.2 fails to buildHexFiend: error: ‘mach_vm_round_page’ was not declared in this scope

It installed fine for me on Snow Leopard, so maybe it's using something that doesn't exist in Leopard.

comment:2 in reply to:  1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign@…:

It installed fine for me on Snow Leopard, so maybe it's using something that doesn't exist in Leopard.

This discussion for BibDesk confirms that mach_vm_round_page was introduced in 10.6.

Changed 9 years ago by neverpanic (Clemens Lang)

Attachment: darwin9.patch added

Can you try with the attached patch against the Portfile and the files directory?

comment:3 Changed 9 years ago by neverpanic (Clemens Lang)

Apparently adding an attachment doesn't trigger a notification mail; can you please try with the attached patch against the Portfile and the files directory?

comment:4 in reply to:  3 Changed 9 years ago by nonstop.server@…

Replying to cal@…:

Apparently adding an attachment doesn't trigger a notification mail; can you please try with the attached patch against the Portfile and the files directory?

Applying the patch against the Portfile and the files directory did not solve the problem.
Before attempting the upgrade I performed a port clean --all to start afresh.
The main.log and terminal output are attached to the ticket.

Changed 9 years ago by nonstop.server@…

Attachment: main_patched.log added

main.log after applying the patch

Changed 9 years ago by nonstop.server@…

terminal output after applying the patch

comment:5 Changed 9 years ago by neverpanic (Clemens Lang)

Missing mach_vm_trunc_page(x) and ProcessPCH fails because it doesn't support -fblocks. I'll try to make a patch for that.

Changed 9 years ago by neverpanic (Clemens Lang)

Attachment: darwin9.2.patch added

revised patch for darwin9

comment:6 Changed 9 years ago by neverpanic (Clemens Lang)

Can you please re-try with the revised patch?

comment:7 in reply to:  6 Changed 9 years ago by nonstop.server@…

Replying to cal@…:

Can you please re-try with the revised patch?

The second patch resolved the issue with the unsupported -fblocks switch.
Now the build fails with some syntax errors.
A new main.log file is attached to the ticket with the details from the build with the second patch applied.

Changed 9 years ago by nonstop.server@…

Attachment: main_2nd_patch.log added

main.log after applying the second patch

comment:8 Changed 9 years ago by neverpanic (Clemens Lang)

Resolution: wontfix
Status: newclosed

Those syntax errors are caused because HexFiend uses anonymous lambda-style functions introduced with grand central dispatch in 10.6 (see https://developer.apple.com/library/mac/#featuredarticles/BlocksGCD/_index.html). There unfortunately is no way to get this code running on any system before 10.6.

I'm afraid you'll probably be stuck at an older version of HexFiend via wiki:howto/InstallingOlderPort.

comment:9 Changed 9 years ago by neverpanic (Clemens Lang)

Summary: HexFiend: error: ‘mach_vm_round_page’ was not declared in this scopeHexFiend doesn't work on systems < 10.6

comment:10 in reply to:  8 Changed 9 years ago by nonstop.server@…

Replying to cal@…:

I'm afraid you'll probably be stuck at an older version of HexFiend via wiki:howto/InstallingOlderPort.

Thank you for your help and the information, it is much appreciated!
I can confirm that version 2.0 of port hexfind is working fine on 10.5 (Leopard), so i'll keep using that version.

% port installed name:hexfiend    
The following ports are currently installed:
  hexfiend @2.0_0 (active)
Note: See TracTickets for help on using tickets.