Opened 9 years ago

Closed 9 years ago

#33223 closed defect (worksforme)

docbook-xml-4.2 checksum error

Reported by: joe@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: docbook-xml-4.2

Description (last modified by ryandesign (Ryan Schmidt))

Hi,

I'm seeing a checksum error when attempting to install docbook-xml-4.2:

% sudo port clean docbook-xml-4.2
--->  Cleaning docbook-xml-4.2
% sudo port install docbook-xml-4.2
--->  Computing dependencies for docbook-xml-4.2
--->  Fetching archive for docbook-xml-4.2
--->  Attempting to fetch docbook-xml-4.2-4.2_0.darwin_9.noarch.tbz2 from http://packages.macports.org/docbook-xml-4.2
--->  Fetching docbook-xml-4.2
--->  Verifying checksum(s) for docbook-xml-4.2
Error: Checksum (md5) mismatch for docbook-xml-4.2.zip
Error: Checksum (sha1) mismatch for docbook-xml-4.2.zip
Error: Checksum (rmd160) mismatch for docbook-xml-4.2.zip
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<https://trac.macports.org/wiki/MisbehavingServers>
***
Error: Target org.macports.checksum returned: Unable to verify file checksums
Log for docbook-xml-4.2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_docbook-xml-4.2/docbook-xml-4.2/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Checking the log, I see:

:info:checksum --->  Checksumming docbook-xml-4.2.zip
:error:checksum Checksum (md5) mismatch for docbook-xml-4.2.zip
:info:checksum Portfile checksum: docbook-xml-4.2.zip md5 73fe50dfe74ca631c1602f
558ed8961f
:info:checksum Distfile checksum: docbook-xml-4.2.zip md5 e4b234d07dad89bc44411f
24da404727
:error:checksum Checksum (sha1) mismatch for docbook-xml-4.2.zip
:info:checksum Portfile checksum: docbook-xml-4.2.zip sha1 5e3a35663cd028c5c5fbb
959c3858fec2d7f8b9e
:info:checksum Distfile checksum: docbook-xml-4.2.zip sha1 ba816a3ca5bc0a5b1ce35
e027519ec012a64770c
:error:checksum Checksum (rmd160) mismatch for docbook-xml-4.2.zip
:info:checksum Portfile checksum: docbook-xml-4.2.zip rmd160 3ba17bf96ab2ab8fe6d
c9ff82da8e22aaf9ce5e0
:info:checksum Distfile checksum: docbook-xml-4.2.zip rmd160 e26ef716887c5141c89
b051017ce8ec10b829f39
:info:checksum The correct checksum line may be:
:info:checksum checksums           md5     e4b234d07dad89bc44411f24da404727 \
                    sha1    ba816a3ca5bc0a5b1ce35e027519ec012a64770c \
                    rmd160  e26ef716887c5141c89b051017ce8ec10b829f39

Checking the host that supplied the mis-checksummed file, it appears to be:

% dig +short packages.macports.org
alpha2.macosforge.org.
17.254.20.158

Thanks for all your work on MacPorts, it's really terrific.

Change History (2)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: docbook-xml-4.2 added

The error message is telling you that the file /opt/local/var/macports/distfiles/docbook-xml-4.2/docbook-xml-4.2.zip is unexpectedly an HTML file. What is in it?

comment:2 Changed 9 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

docbook-xml-4.2.zip did not come from packages.macports.org; it had already been fetched. It attempted to fetch docbook-xml-4.2-4.2_0.darwin_9.noarch.tbz2 from packages.macports.org but it was not there, so it then fell back to building from source.

I can't reproduce this, so if you reopen, please generate a complete log by running

sudo port clean --dist docbook-xml-4.2
sudo port checksum docbook-xml-4.2
Note: See TracTickets for help on using tickets.