Opened 9 years ago

Closed 17 months ago

#33262 closed defect (fixed)

GTK2 build fails in 10.4.11 because system CUPS is too old

Reported by: macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: tiger Cc: drkp (Dan Ports)
Port: gtk2

Description

GTK2 build on 10.4.11 (Mac Mini) fails with the following log excerpt:

*

:info:build libtool: compile:  /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I../../.. -I../../.. -I../../../gtk -I../../../gtk -I../../../gdk -I../../../gdk -DGTK_PRINT_BACKEND_ENABLE_UNSUPPORTED -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/pango-1.0 -I/opt/local/include/cairo -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I/opt/local/include/libpng14 -I/opt/local/include/gio-unix-2.0/ -I/opt/local/include/gdk-pixbuf-2.0 -I/opt/local/include/atk-1.0 -DG_DISABLE_CAST_CHECKS -I/opt/local/include -DX_LOCALE -DG_DISABLE_SINGLE_INCLUDES -DATK_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_SINGLE_INCLUDES -DGTK_DISABLE_SINGLE_INCLUDES -I/opt/local/include -DGDK_PIXBUF_DISABLE_DEPRECATED -O2 -fstrict-aliasing -arch i386 -Wall -MT gtkprintbackendcups.lo -MD -MP -MF .deps/gtkprintbackendcups.Tpo -c gtkprintbackendcups.c  -fno-common -DPIC -o .libs/gtkprintbackendcups.o
:info:build gtkprintbackendcups.c: In function 'add_cups_options':
:info:build gtkprintbackendcups.c:516: error: 'ppd_coption_t' undeclared (first use in this function)
:info:build gtkprintbackendcups.c:516: error: (Each undeclared identifier is reported only once
:info:build gtkprintbackendcups.c:516: error: for each function it appears in.)
:info:build gtkprintbackendcups.c:516: error: 'coption' undeclared (first use in this function)
:info:build gtkprintbackendcups.c:520: warning: implicit declaration of function 'ppdFindCustomOption'
:info:build make[4]: *** [gtkprintbackendcups.lo] Error 1

*

Possible wrong API selection? I can find no "ppd_coption_t" structure in the headers, nor any function ppdFindCustomOption().

Attachments (1)

main.log (1.8 MB) - added by macports@… 9 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Keywords: tiger added; GTK2 ppd removed

Please attach the complete main.log

Changed 9 years ago by macports@…

Attachment: main.log added

comment:2 Changed 9 years ago by macports@…

I performed a clean and rebuild for the attached log.

comment:3 Changed 9 years ago by mf2k (Frank Schima)

Port: gtk2 added; GTK2 removed
Resolution: wontfix
Status: newclosed

Closing as won't fix because there is no port maintainer and Tiger is not supported by Macports unless the maintainer wants to. So this is not likely to ever get fixed. You can re-open the ticket with a patch however. Perhaps try installing gtk3 as a workaround.

comment:4 Changed 9 years ago by mf2k (Frank Schima)

See also #15132. This may be a duplicate of that ticket.

comment:5 Changed 9 years ago by macports@…

Then how does one remove the package from upgrade lists without removing the installed version? Gtk2 is used by at least 5 other installed packages, which I try to keep current.

I think I'm going to make this machine a Linux box and NEVER AGAIN buy any product made or sold by Apple,Inc!

comment:6 Changed 9 years ago by drkp (Dan Ports)

Cc: dports@… added
Resolution: wontfix
Status: closedreopened

comment:7 Changed 9 years ago by drkp (Dan Ports)

Resolution: fixed
Status: reopenedclosed

Looks like gtk2 now requires a newer version of CUPS than is available in Tiger.

I've disabled gtk2's cups support for Tiger in r89955. (It was already disabled for +universal on Tiger for a different reason.) That's probably the best we can do, given that Tiger is unsupported.

comment:8 Changed 9 years ago by macports@…

Seems OK for now. Thanks much for that!

comment:9 Changed 9 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: closedreopened

We should really look into not relying on the host's cups...

comment:10 Changed 8 years ago by jmroot (Joshua Root)

Summary: GTK2 build fails in 10.4.11GTK2 build fails in 10.4.11 because system CUPS is too old

comment:11 in reply to:  9 Changed 17 months ago by jmroot (Joshua Root)

Resolution: fixed
Status: reopenedclosed

Replying to jeremyhu:

We should really look into not relying on the host's cups...

If after 7 years someone wants to work on that, please open a separate ticket.

Note: See TracTickets for help on using tickets.