New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #33283 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

libvpx @0.9.7-p1 Build error due to wrong SDK path for Xcode 4.3 in patch-build-make-configure.sh.diff

Reported by: m.haller@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: lukasz@…, domiman@…, cal@…, eimantas@…, jonas@…, calvin@…
Port: libvpx

Description

info: Mac OS X 10.7.3 / Xcode 4.3 / Xcode command line tools installed

build phase for libvpx fails due to wrong SDK path setting in patch file patch-build-make-configure.sh.diff

Currently the patch adds

+        *-darwin11-*)
+            add_cflags  "-isysroot @DEVELOPER_DIR@/SDKs/MacOSX10.7.sdk"
+            add_cflags  "-mmacosx-version-min=10.7"
+            add_ldflags "-isysroot @DEVELOPER_DIR@/SDKs/MacOSX10.7.sdk"
+            add_ldflags "-mmacosx-version-min=10.7"
+            ;;

BUT, the Xcode 4.3 SDK path for 10.7 is

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk

Similar problem occurs in portconfigure.tcl where the sdk directory is set.

Change History

comment:1 Changed 2 years ago by ryandesign@…

Xcode 4.3 was just released and several aspects of MacPorts 2.0.3 and the ports we currently have are probably incompatible with it. I recommend you use Xcode 4.2.x until we can sort this out.

comment:2 Changed 2 years ago by ryandesign@…

comment:3 Changed 2 years ago by lukasz@…

  • Cc lukasz@… added

Cc Me!

comment:4 Changed 2 years ago by domiman@…

  • Cc domiman@… added

Cc Me!

comment:5 Changed 2 years ago by ryandesign@…

  • Status changed from new to closed
  • Cc cal@… added
  • Resolution set to fixed
  • Port set to libvpx

comment:6 Changed 2 years ago by cal@…

Has duplicate #33351.

Had this bug the port field set correctly I would have seen and closed it after the commit (and I wouldn't have had to find out why this fails on my own…).

comment:7 Changed 2 years ago by eimantas@…

  • Cc eimantas@… added

Cc Me!

comment:8 Changed 2 years ago by jonas@…

  • Cc jonas@… added

Cc Me!

comment:9 Changed 2 years ago by calvin@…

Hello, as a point of interest, you guys might like to refer to how I solve the same problem, though in my case, I was simply building the c extensions for readline via pip and not port.

But I believe the problem is the same and I used symlink to solve it temporarily.

Reference - http://stackoverflow.com/questions/10150493/pip-install-readline-on-mac-os-x-10-7-3-fails

comment:10 Changed 2 years ago by cal@…

Messing around and creating symlinks in what is clearly a hierarchy managed by the vendor (Apple in this case) is not an acceptable solution for such a problem.

comment:11 Changed 2 years ago by cal@…

  • Cc calvin@… added
Note: See TracTickets for help on using tickets.