Opened 10 years ago

Closed 10 years ago

#33285 closed defect (worksforme)

libvpx does not build on SnowLeopard + XCode 3.2.6 + i386

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: libvpx

Description (last modified by jeremyhu (Jeremy Huddleston Sequoia))

My SL box hit a snag updating when it came across libvpx. Reverting r82638 allowed it to build the previous version successfully, so it seems to be an issue with the newer version brought in by that commit.

:info:build yasm -f macho32 -I./ -I"/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_multimedia_libvpx/libvpx/work/libvpx-v0.9.7-p1"/ -o vp8/encoder/x86/quantize_sse2.asm.o vp8/encoder/x86/quantize_sse2.asm
:info:build asm_enc_offsets.asm:1: error: instruction expected after label
:info:build asm_enc_offsets.asm:1: warning: no non-local label before `.ascii'
:info:build asm_enc_offsets.asm:2: error: `%0': not in a macro call
:info:build asm_enc_offsets.asm:2: error: instruction expected after label
:info:build asm_enc_offsets.asm:2: warning: no non-local label before `.ascii'
:info:build asm_enc_offsets.asm:2: warning: ignoring unrecognized character `\'
:info:build asm_enc_offsets.asm:2: warning: ignoring unrecognized character `\'
:info:build asm_enc_offsets.asm:2: warning: ignoring unrecognized character `\'
:info:build asm_enc_offsets.asm:2: warning: ignoring unrecognized character `\'
:info:build asm_enc_offsets.asm:2: warning: ignoring unrecognized character `\'
:info:build asm_enc_offsets.asm:2: error: instruction expected after label
:info:build asm_enc_offsets.asm:2: warning: no non-local label before `.ascii'
:info:build asm_enc_offsets.asm:2: error: instruction expected after label
:info:build asm_enc_offsets.asm:2: warning: no non-local label before `.ascii'
:info:build asm_enc_offsets.asm:2: error: instruction expected after label
:info:build asm_enc_offsets.asm:2: warning: no non-local label before `.ascii'
:info:build asm_enc_offsets.asm:2: error: instruction expected after label
:info:build asm_enc_offsets.asm:2: warning: no non-local label before `.ascii'
:info:build asm_enc_offsets.asm:2: error: instruction expected after label
:info:build asm_enc_offsets.asm:2: warning: no non-local label before `.ascii'
:info:build asm_enc_offsets.asm:2: error: instruction expected after label
:info:build asm_enc_offsets.asm:2: warning: no non-local label before `.ascii'
:info:build asm_enc_offsets.asm:2: error: instruction expected after label
:info:build asm_enc_offsets.asm:2: warning: no non-local label before `.ascii'
:info:build make[1]: *** [vp8/encoder/x86/quantize_sse2.asm.o] Error 1

Attachments (1)

main.log (146.3 KB) - added by jeremyhu (Jeremy Huddleston Sequoia) 10 years ago.
main.log

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Attachment: main.log added

main.log

comment:1 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Description: modified (diff)

comment:2 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

After bumping to v1.0.0, the issue is now:

yasm -f macho32 -I./ -I"/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_multimedia_libvpx/libvpx/work/libvpx-v1.0.0"/ -o vp8/encoder/x86/quantize_sse2.asm.o vp8/encoder/x86/quantize_sse2.asm
asm_enc_offsets.asm:1: error: `%0': not in a macro call
asm_enc_offsets.asm:1: error: instruction expected after label
asm_enc_offsets.asm:1: warning: no non-local label before `.ascii'
asm_enc_offsets.asm:1: warning: ignoring unrecognized character `\'
asm_enc_offsets.asm:1: warning: ignoring unrecognized character `\'
asm_enc_offsets.asm:1: warning: ignoring unrecognized character `\'
asm_enc_offsets.asm:1: warning: ignoring unrecognized character `\'
asm_enc_offsets.asm:1: warning: ignoring unrecognized character `\'
make[1]: *** [vp8/encoder/x86/quantize_sse2.asm.o] Error 1

comment:3 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Johann <johannkoenig@…> seems to be the maintainer of those bits, so I'm emailing him about the issue.

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Owner: changed from ryandesign@… to macports-tickets@…

I have no trouble building libvpx 1.0.0 or 0.9.7-p1, on my 64-bit Mac with Snow Leopard and Xcode 3.2.6, compiling for i386 alone or universal for x86_64 i386.

I note the error comes from yasm, and I do have the yasm port installed. Do you? If not, perhaps we need to add a dependency on it.

comment:5 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: worksforme
Status: newclosed

Ok, this is happening because on that system, I build with -ggdb3, and there are some errors in the build system dealing with debug symbols.

SInce we don't actually support users changing those flags, I'm closing this radar.

Note: See TracTickets for help on using tickets.