Opened 18 years ago

Closed 17 years ago

Last modified 16 years ago

#333 closed defect (fixed)

dependancy failure are ignored and port continues to try and install

Reported by: michaelm@… Owned by: kvv@…
Priority: Normal Milestone:
Component: base Version: 1.0
Keywords: Cc: ssen@…
Port:

Description

when executing port install, dependancies are checked for, and if missing installed. However if the installation of the dependancy fails, ports continues onto the next dep, or the initial port (which will eventually fail through a missing dependancy).

Change History (5)

comment:1 Changed 18 years ago by jpm@…

additionally if a failure is caused before deps are even evaluated (checksum mismatch for example), deps are still installed - odd.

comment:2 Changed 18 years ago by kevin@…

Status: newassigned

Committing some stuff tonight which I'll comment further on the list which should fix these sorts of problems.

comment:3 Changed 18 years ago by kevin@…

Cc: ssen@… added

comment:4 Changed 18 years ago by kevin@…

* Bug 354 has been marked as a duplicate of this bug. *

comment:5 Changed 17 years ago by landonf@…

Resolution: fixed
Status: assignedclosed

This is now fixed

Note: See TracTickets for help on using tickets.