Opened 9 years ago

Closed 9 years ago

#33646 closed defect (invalid)

subversion-perlbindings build script looks in the wrong path for clang

Reported by: ksze (Kal Sze) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: clang xcode developer_dir Cc:
Port: subversion-perlbindings

Description

I just tried upgrading subversion-perlbindings today and it failed. It appears that the build script is still using a hardcoded path to clang ("/Developer/usr/bin/clang"), even though I have already uninstalled Xcode 4.2.1 and installed Xcode 4.3.1.

My output of xcode-select -print-path is "/Applications/Xcode.app/Contents/Developer", and I don't have the developer_dir directive set in "/opt/local/etc/macports/macports.conf".

Note, however, that Xcode 4.3.1 doesn't seem to come with clang at all, even with the "Command Line Tools" package. The only copy of clang I have right now seems to be at /usr/bin/clang.

I'm using MacPorts 2.0.4, Xcode 4.3.1 with Command Line Tools package, on Mac OS X 10.7.3 Lion.

Attachments (1)

main.log (7.4 KB) - added by ksze (Kal Sze) 9 years ago.
Main log

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by ksze (Kal Sze)

Attachment: main.log added

Main log

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Rebuild libtool and apr. This has come up several times on the list already. We should update wiki:ProblemHotlist#xcode43 to include libtool and apr.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Of course Xcode 4.3.1 comes with clang.

comment:3 in reply to:  1 Changed 9 years ago by ksze (Kal Sze)

Replying to ryandesign@…:

Rebuild libtool and apr. This has come up several times on the list already. We should update wiki:ProblemHotlist#xcode43 to include libtool and apr.

I just rebuilt libtool and apr, by running:

port -n upgrade --force libtool apr

And then I cleaned subversion-perlbindings using:

port clean subversion-perlbindings

Finally, I retried the upgrade:

port upgrade subversion-perlbindings

I still get the same error, however.

comment:4 in reply to:  2 Changed 9 years ago by ksze (Kal Sze)

Replying to ryandesign@…:

Of course Xcode 4.3.1 comes with clang.

You are right, Xcode 4.3.1 does come with clang. It's just not where I expect it to be ("/Applications/Xcode.app/Contents/Developer/usr/bin/"). Instead I find it at 2 other places:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/clang

/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang

comment:5 Changed 9 years ago by ksze (Kal Sze)

So according to neverpan1c and Raim in the #macports IRC channel on Freenode, I have to rebuild perl5.12, too:

port -n upgrade --force perl5.12

I did that and the problem is gone.

comment:6 Changed 9 years ago by danielluke (Daniel J. Luke)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.