Opened 15 years ago

Closed 15 years ago

#3378 closed enhancement (duplicate)

NEW: Portfile for pgAdmin3

Reported by: jyrki.wahlstedt@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

I have built an initial Portfile for pgAdmin3. A couple of points: handling of mirrors for source (mirrors provided by PostgreSQL org) and what is the best way for support of both 7 & 8. Unfortunately I don't currently have a clean system, so I can't test in on other systems.

Attachments (6)

Portfile (1.5 KB) - added by jyrki.wahlstedt@… 15 years ago.
Portfile for pgAdmin3
patch-configure (585 bytes) - added by jyrki.wahlstedt@… 15 years ago.
patch for pgAdmin3 configure
patch-complete-bundle.sh (1.5 KB) - added by jyrki.wahlstedt@… 15 years ago.
patch to create pgAdmin3 bundle completing shell script (missing from the archive)
pgAdmin3.log (2.7 KB) - added by olegb@… 15 years ago.
buildlog
Portfile.2 (1.5 KB) - added by jyrki.wahlstedt@… 15 years ago.
Portfile: pgAdmin3 1.2.2
Portfile.3 (1.5 KB) - added by jyrki.wahlstedt@… 15 years ago.
Portfile: pgAdmin3 1.2.2

Download all attachments as: .zip

Change History (12)

Changed 15 years ago by jyrki.wahlstedt@…

Attachment: Portfile added

Portfile for pgAdmin3

Changed 15 years ago by jyrki.wahlstedt@…

Attachment: patch-configure added

patch for pgAdmin3 configure

Changed 15 years ago by jyrki.wahlstedt@…

Attachment: patch-complete-bundle.sh added

patch to create pgAdmin3 bundle completing shell script (missing from the archive)

comment:1 Changed 15 years ago by jyrki.wahlstedt@…

op_sys: Mac OS X 10.0Mac OS X 10.4
Priority: nice to haveexpected
Summary: RFC: Portfile for pgAdmin3NEW: Portfile for pgAdmin3

Changed 15 years ago by olegb@…

Attachment: pgAdmin3.log added

buildlog

comment:2 Changed 15 years ago by jyrki.wahlstedt@…

(In reply to comment #4)

Created an attachment (id=2542) [edit] buildlog

this fails to pickup the dep installed postgresql

m00:~/testports/pgAdmin3 olegb$ port installed | grep post

postgresql8 8.0.3_0 (active)

m00:~/testports/pgAdmin3 olegb$

Ok, I'll attach a new Portfile with the following changes:

  • changed lib:libpq: to port:
  • added a configuration argument --with-pgsql=${prefix} that would be the reason to the failure

above, as /opt/local is not searched by default

Changed 15 years ago by jyrki.wahlstedt@…

Attachment: Portfile.2 added

Portfile: pgAdmin3 1.2.2

comment:3 Changed 15 years ago by jyrki.wahlstedt@…

attachments.isobsolete: 01

comment:4 Changed 15 years ago by jyrki.wahlstedt@…

(In reply to comment #5)

I'll attach a new Portfile with the following changes:

  • changed lib:libpq: to port:
  • added a configuration argument --with-pgsql=${prefix} that would be the reason to the failure

above, as /opt/local is not searched by default

I changed my older machine to a test computer (with DP in /opt/local) and found out that one change is still necessary (adding to configuration --with-wx=${prefix}). The modified Portfile is attached. This builds the app in the test computer

Changed 15 years ago by jyrki.wahlstedt@…

Attachment: Portfile.3 added

Portfile: pgAdmin3 1.2.2

comment:5 Changed 15 years ago by jyrki.wahlstedt@…

attachments.isobsolete: 01

comment:6 Changed 15 years ago by mww@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 5769 *

Note: See TracTickets for help on using tickets.