Opened 9 years ago

Closed 9 years ago

#33835 closed defect (worksforme)

gsed fails to intall due to a checksum error

Reported by: paul@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc:
Port: gsed

Description

The MD5 of the tarball is "28a22ce3f1af5702a2542082c5340630" but the portfile is looking for "f0fd4d7da574d4707e442285fd2d3b86"

BM-MAC13-2:~ dev$ sudo port install gsed
--->  Computing dependencies for gsed
--->  Fetching archive for gsed
--->  Attempting to fetch gsed-4.2.1_2.darwin_11.x86_64.tbz2 from http://packages.macports.org/gsed
--->  Fetching gsed
--->  Verifying checksum(s) for gsed
Error: Checksum (md5) mismatch for sed-4.2.1.tar.gz
Error: Checksum (sha1) mismatch for sed-4.2.1.tar.gz
Error: Checksum (rmd160) mismatch for sed-4.2.1.tar.gz
Error: Target org.macports.checksum returned: Unable to verify file checksums
Log for gsed is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_gsed/gsed/main.log
Error: Status 1 encountered during processing.

Change History (4)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Port: gsed added

See wiki:FAQ#checksums. What URL did the bad file come from? (The answer is not http://packages.macports.org/gsed)

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

I just checked all the servers offering this file; they either all have a file of that size, or return a 404 Not Found error (which MacPorts would handle correctly by trying a different server).

You may have just gotten an incomplete download. You could check the file that got downloaded (/opt/local/var/macports/distfiles/gsed/sed-4.2.1.tar.gz); if it is less than 1152453 bytes, it's incomplete and you should "sudo port clean --all gsed" and try again.

If it fails again, show us what URL the bad distfile was downloaded from so we can investigate further.

comment:3 Changed 9 years ago by paul@…

Hmm... I can't reproduce on my end here. I think you're dead right in that I had a failed download. I'd thought that "port clean gsed" would do the trick, but after running "port clean --all gsed" I'm back in business.

Thanks for giving me a hand with this, and sorry for the false alarm!

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

"clean" only cleans the work directory. If it thinks it successfully downloaded a distfile, it won't delete it unless you "clean --all" (or "clean --dist").

Note: See TracTickets for help on using tickets.