Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#33848 closed submission (fixed)

py-openbabel unified port

Reported by: atenderholt@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc: mlund@…
Port: py-openbabel

Description

Python 2.7 bindings for OpenBabel 2.3.0 would be nice...

Mostly based on the older py26-openbabel Portfile, with modifications because it exited with an error unless the build target is changed to build_ext with a flag for location of OpenBabel sources.

Is there a way to ensure the proper version of openbabel is installed first? I didn't see anything in the documentation about version, just having port:openbabel as a dependency.

Adam --

Attachments (1)

Portfile (1.7 KB) - added by atenderholt@… 9 years ago.
unified Porfile for the python bindings of openbabel

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Instead of making a new py27-openbabel port, please create a unified py-openbabel port.

There is only one version of any given port available in MacPorts at any one time, and MacPorts will ensure dependencies are upgraded first. So if you declare a dependency on openbabel, MacPorts will ensure that the currently-available version of openbabel in MacPorts is installed first, before trying to build py-openbabel.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Since the python module port uses the same distfile as the openbabel port, and should really be kept in sync with the openbabel port's version number, the simplest way to ensure that might be to make the python modules subports of the openbabel port.

comment:3 in reply to:  1 ; Changed 9 years ago by atenderholt@…

Replying to ryandesign@…:

Instead of making a new py27-openbabel port, please create a unified py-openbabel port.

Nearly all of the python packages lack a unified port (eg. py??-pyqt4, py??-numpy, py??-sicpy). Should py-openbabel break away from this trend?

comment:4 in reply to:  2 Changed 9 years ago by atenderholt@…

Replying to ryandesign@…:

Since the python module port uses the same distfile as the openbabel port, and should really be kept in sync with the openbabel port's version number, the simplest way to ensure that might be to make the python modules subports of the openbabel port.

For some reason, the openbabel port specifically disables the python bindings from being built. Should this be changed for openbabel, and the pyxx-openbabel ports be removed?

comment:5 in reply to:  3 ; Changed 9 years ago by mf2k (Frank Schima)

Replying to atenderholt@…:

Nearly all of the python packages lack a unified port (eg. py??-pyqt4, py??-numpy, py??-sicpy). Should py-openbabel break away from this trend?

Huh? All of those are unified. The way forward is to unify the python ports.

comment:6 in reply to:  5 Changed 9 years ago by atenderholt@…

Replying to macsforever2000@…:

Huh? All of those are unified. The way forward is to unify the python ports.

Last week when I was working on this, the non-unified versions were still available on my computer. Maybe I hadn't recently done a selfupdate? Or the non-unified version are still in the repository?

At any rate, is there a webpage describing how to create unified python ports? Or is it best to just copy and modify a unified port?

comment:7 Changed 9 years ago by mf2k (Frank Schima)

Those ports have been unified for a long time - many months.

Short of examining the python 1.0 portgroup sourcecode, definitely use a unified port as an example. py-pil is a good and not too complex unified python portfile to start with.

Changed 9 years ago by atenderholt@…

Attachment: Portfile added

unified Porfile for the python bindings of openbabel

comment:8 Changed 9 years ago by atenderholt@…

I've attached a new unified Porfile using py-pil as a guide.

Is it possible to rename this ticket to reflect that it's now about py-openbabel? There are also tickets for py26-openbabel (which should be closed and marked as a duplicate of this or a new py-openbabel ticket?) and openbabel (I created a patched Portfile earlier today).

comment:9 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Port: py-openbabel added
Status: newassigned
Summary: new port: py27-openbabelpy-openbabel unified port

comment:10 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Deleted py26-openbabel in r93013 and added py-openbabel based on it in r93014.

Note: See TracTickets for help on using tickets.