Opened 9 years ago

Closed 9 years ago

#33850 closed defect (duplicate)

libiodbc: unknown type name 'u_short'

Reported by: dhuffkc@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc: nerdling (Jeremy Lavergne)
Port: libiodbc

Description (last modified by ryandesign (Ryan Schmidt))

I have a new install of Lion with XCode 4.3 and MacPorts 2.0.4. I am trying to build Kdenlive. Libiodbc is failing with:

:info:build In file included from confirm.c:77:
:info:build ../../iodbcinst/unicode.h:116:5: error: unknown type name 'u_short'; did you mean 'short'?
:info:build     u_short * result);
:info:build     ^

Log attached after "sudo port clean libiodbc" and "sudo port install libiodbc".

Any help is appreciated...thanks,

Don

Attachments (1)

main.log (353.1 KB) - added by dhuffkc@… 9 years ago.
libiodbc main.log

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by dhuffkc@…

Attachment: main.log added

libiodbc main.log

comment:1 Changed 9 years ago by dhuffkc@…

Cc: dhuffkc@… added

Cc Me!

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: snc@… added; dhuffkc@… removed
Description: modified (diff)
Keywords: libiodbc kdenlive unkown type name removed
Resolution: duplicate
Status: newclosed

Please remember to use WikiFormatting when writing in Trac.

As reporter it is not necessary to Cc yourself.

Please search for existing tickets before filing a new one. This is a duplicate of #33833.

Note: See TracTickets for help on using tickets.