Opened 9 years ago

Closed 9 years ago

#33856 closed defect (duplicate)

cairo install fails with libspectre errors (trying to install wine)

Reported by: eravin@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc:
Port: cairo

Description (last modified by ryandesign (Ryan Schmidt))

I'm trying to install wine on a Snow Leopard Mac.

Here's what happens when I try:

bash-3.2# port install wine
--->  Computing dependencies for cairo
--->  Building cairo
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for cairo is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_cairo/cairo/main.log
Error: Unable to upgrade port: 1
Error: Unable to execute port: upgrade gst-plugins-base failed
To report a bug, see <http://guide.macports.org/#project.tickets>

And the log file contains:

:info:build Undefined symbols::info:build   "_spectre_render_context_set_page_size", referenced from:
:info:build       _ps_convert in any2ppm-any2ppm.o
:info:build   "_spectre_page_free", referenced from:
:info:build       _ps_convert in any2ppm-any2ppm.o
:info:build   "_spectre_document_status", referenced from::info:build       _ps_convert in any2ppm-any2ppm.o
:info:build   "_spectre_page_status", referenced from::info:build       _ps_convert in any2ppm-any2ppm.o
:info:build   "_spectre_status_to_string", referenced from:
:info:build       _ps_convert in any2ppm-any2ppm.o
:info:build       _ps_convert in any2ppm-any2ppm.o
:info:build   "_spectre_document_render", referenced from:
:info:build       _ps_convert in any2ppm-any2ppm.o
:info:build   "_spectre_page_render", referenced from:
:info:build       _ps_convert in any2ppm-any2ppm.o
:info:build   "_spectre_document_new", referenced from:
:info:build       _ps_convert in any2ppm-any2ppm.o
[...]
[a bunch more similar errors]
[...]
:info:build ld: symbol(s) not found
:info:build collect2: ld returned 1 exit status
:info:build make[4]: *** [any2ppm] Error 1

I have already done "port selfupdate" and upgraded all outdated ports.

On a lark, I did "port uninstall libspectre". Now, when I do "port wine install", I get a different error in the build for cairo:

:info:build ld: library not found for -lspectre:info:build collect2: ld returned 1 exit status

Shouldn't macports have tried to re-install libspectre?

Note, I already have cairo installed:

bash-3.2# port installed "cairo*"
The following ports are currently installed:
  cairo @1.12.0_0+x11 (active)

But it looks like macports is trying to build

cairo@1.12.0_0+universal+x11

Attachments (1)

main.log (80.5 KB) - added by eravin@… 9 years ago.
log from failed cairo build

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by eravin@…

Attachment: main.log added

log from failed cairo build

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Port: cairo added

Please remember to use WikiFormatting.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #33827.

Note: See TracTickets for help on using tickets.