Opened 9 years ago

Closed 9 years ago

#33952 closed defect (duplicate)

Pallet 1.1 needs update for Growl 1.2.2

Reported by: dave@… Owned by: juanger@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc:
Port: Pallet

Description

Pallet needs to be updated for Growl version 1.2.2 error:

Error: Target org.macports.build returned: shell command failed (see log for details)
Log for Pallet is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

log:

:info:build strip: for architecture x86_64 object: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/work/Pallet/Growl-1.2.1-Framework/Growl.framework/Versions/A/Growl malformed object (unknown load command 5)
:info:build pbxcp: warning: couldn't strip: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/work/Pallet/build/Release/Pallet.app/Contents/Frameworks/Growl.framework/Versions/A/Growl: No such file or directory
:info:build ** BUILD FAILED **
:info:build 
:info:build The following build commands failed:
:info:build Pallet:
:info:build 	PBXCp build/Release/Pallet.app/Contents/Frameworks/Growl.framework Growl-1.2.1-Framework/Growl.framework
:info:build (1 failure)
:info:build 
:info:build shell command "cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/work/Pallet" && /usr/bin/xcodebuild  -target "Pallet" -configuration Release build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.5 ARCHS=ppc SDKROOT="" GCC_VERSION=4.0 FRAMEWORK_SEARCH_PATHS='/opt/local/Library/Frameworks Growl-1.2.1-Framework'" returned error 1
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"$procedure $targetname"
:info:build Warning: the following items did not execute (for Pallet): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for Pallet is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_Pallet/Pallet/main.log
 

Attachments (2)

PalletLog.txt (23.4 KB) - added by dave@… 9 years ago.
Console Log
PalletLogNew.txt (81.3 KB) - added by dave@… 9 years ago.
New Pallet Log

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by dave@…

Attachment: PalletLog.txt added

Console Log

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to juanger@…

I don't understand... does Pallet use Growl? It does not declare a dependency on the Growl port. Even if it did, the Growl port is version 1.1.6, not 1.2.2.

The log you attached mentions Growl 1.2.1. But the log is also incomplete (contains lines saying "Skipping completed") so please "sudo port clean Pallet" and try again, then attach the new main.log.

Changed 9 years ago by dave@…

Attachment: PalletLogNew.txt added

New Pallet Log

comment:2 Changed 9 years ago by dave@…

comment:3 Changed 9 years ago by sierkb@…

Wouldn't it be better to update Pallet's Growl Framework to at least version 1.3.1 than to 1.2.2?

See also http://lists.macosforge.org/pipermail/macports-dev/2012-April/018739.html on macports-dev.

comment:4 Changed 9 years ago by jmroot (Joshua Root)

Yes, however as Ryan said, the Pallet port should really use the Growl port rather than embedding its own copy, and the Growl port should be updated to the current version.

comment:5 Changed 9 years ago by dave@…

The newest free version is 1.2.2. Any newer versions cost and are only available at the Mac App Store.

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #27180.

Note: See TracTickets for help on using tickets.