Opened 9 years ago

Closed 8 years ago

#34066 closed update (invalid)

gmt4 update to 4.5.8

Reported by: florian@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: tenomoto (Takeshi Enomoto)
Port: gmt4, gshhg-gmt-nc4

Description

Port gmt4 now depends on port gshhg-gmt-nc4 (#34065).

Attachments (6)

patch-bugfixes.diff (41.9 KB) - added by florian@… 9 years ago.
patchfile 1
patch-gmt_shore_c.diff (707 bytes) - added by florian@… 9 years ago.
patchfile 2
Portfile.diff (4.0 KB) - added by florian@… 9 years ago.
Portfile patch
Portfile.spacing.diff (4.2 KB) - added by florian@… 9 years ago.
Portfile change spacing
patch-bugfixes-r9794.diff (40.8 KB) - added by florian@… 9 years ago.
patchfile 1a
patch-bugfixes-r9816.diff (8.3 KB) - added by florian@… 9 years ago.
patchfile 1b

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by florian@…

Attachment: patch-bugfixes.diff added

patchfile 1

Changed 9 years ago by florian@…

Attachment: patch-gmt_shore_c.diff added

patchfile 2

comment:1 Changed 9 years ago by florian@…

Sorry, this is an update request not a defect.

comment:2 Changed 9 years ago by tenomoto (Takeshi Enomoto)

Sorry for slow response. Your changes seem to be OK but I will have to do two commits: one for the main changes and the other for white space change. BTW where does patch-bugfixes.diff come from? Did you find all the bugs? Usually we create a patch for each file but the problem is that there are so many files to patch. Are the developers going to adopt these patches in the future version (4.5.8.1 or 4.5.9)?

Changed 9 years ago by florian@…

Attachment: Portfile.diff added

Portfile patch

Changed 9 years ago by florian@…

Attachment: Portfile.spacing.diff added

Portfile change spacing

Changed 9 years ago by florian@…

Attachment: patch-bugfixes-r9794.diff added

patchfile 1a

Changed 9 years ago by florian@…

Attachment: patch-bugfixes-r9816.diff added

patchfile 1b

comment:3 in reply to:  2 Changed 9 years ago by florian@…

Sorry for slow response. Your changes seem to be OK but I will have to do two commits: one for the main changes and the other for white space change.

No worries. I attached two Portfile patches - one for the spacing and one for everything else.

BTW where does patch-bugfixes.diff come from? Did you find all the bugs? Usually we create a patch for each file but the problem is that there are so many files to patch. Are the developers going to adopt these patches in the future version (4.5.8.1 or 4.5.9)?

I'm aware that patch-bugfixes.diff contains quite a lot of hunks. But these are important fixes from svn. They are mostly related to xgrid. I just added xgird as a variant in the reattached Portfile patch. All bugfixes and the changes from patch-gmt_shore_c.diff will be integrated into the next release 4.5.9. Please ignore patch-bugfixes.diff and commit patch-bugfixes-r9794.diff and patch-bugfixes-r9816.diff instead.

comment:4 Changed 9 years ago by jmroot (Joshua Root)

Cc: takeshi@… added; takeshi removed
Type: defectupdate
Version: 2.0.4

comment:5 Changed 8 years ago by tenomoto (Takeshi Enomoto)

Resolution: invalid
Status: newclosed

Obsoleted by #37553 .

Note: See TracTickets for help on using tickets.